Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

APIs redirecting to SSO login page

maurabagley
New Contributor
New Contributor
We need to use the Sav4Sav REST connection to add Sav roles.  This is working fine in dev which does not have SSO enabled.  In production, where SSO is enabled, it is redirecting to the SSO login page.

Per the forum, we did the following:
1. Create User
2. Set localauthenabled=1 (true)
3. Change password via 'Admin Function' to desired password
4. Set passwordexpired=0 (false)
We then set localauthenabled=0 since the forum said that wouldn't hurt.
 
Using Postman, we got a valid Bearer token.  We updated the ConnectionJSON and it connects.  Note:  The ConnectionJSON has a testconnection step.
 
In Postman, we I run any of the APIs, I receive a 200 status but the body returned is the SSO login page.
9 REPLIES 9

maurabagley
New Contributor
New Contributor

Never mind.  All set.

Dave
Community Manager
Community Manager

To help future users who may experience a similar situation, what did you do to correct the situation? 

BarCar
Regular Contributor
Regular Contributor

@maurabagley - I'm seeing this too - can you please shared your solution?

Sampo
New Contributor III
New Contributor III

We had a similar issue some time ago and it was resolved by turning off the SSO for a while. Then we tried to log in to UI with the technical user and found out that Saviynt wanted to set up security questions and answers for the user. API calls worked after security questions&answers were set up and SSO was re-enabled. Not sure if we could have set them using a DB update instead.

Kramerica
New Contributor II
New Contributor II

@maurabagley  - Can you please share the solution? We are facing the same issue.

Kramerica
New Contributor II
New Contributor II

@BarCar  Were you able to resolve this?

gauravchandok
Regular Contributor
Regular Contributor

Hey everyone

Do we have solution to this issue?

Kramerica
New Contributor II
New Contributor II

In global configurations, uncheck following setting and give it a try.

 

Kramerica_0-1699381288713.png

 

gauravchandok
Regular Contributor
Regular Contributor

I played around and have logged in using that user via SSO, as our SSO is configured to work on saviynt email so i put my team mate's email address in this API user and logged in and set the security questions.

I have set the localAuthEnabled as 1 and try to execute the authentication API but i always get Invalid username or password error although I am passing the correct info.

Thanks