Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Actionable email job returns "Failure:EOF on socket"

Joon
Regular Contributor II
Regular Contributor II

Hello Folks,

I have tried to set out-mailbox for Actionable email.

the assignee got the email through the template and was able to reply via click "accept" button in the template.

and found it has been sent to the inbox that i set on out-mailbox set up, but When i run the job of Email based approval job" it has returned "Failure:EOF on socket"

I have tried both POP3/iMAP with the corresponding port number, got the still same error.

i am attaching the set up 

Joon_1-1673360063361.png

Joon_2-1673360185859.png

 

 

 

10 REPLIES 10

rushikeshvartak
All-Star
All-Star

It should be pop3s 

https://help.mulesoft.com/s/article/Email-Pop3-connector-POP3-authentication-command-failed--javax-m...


Regards,
Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.

Joon
Regular Contributor II
Regular Contributor II

Hello Rushikesh,

So i tried 995 port. How could i solve this ?

Joon
Regular Contributor II
Regular Contributor II

I got successfully authenticated by Oauth.

but it prints this error code meanwhile there are the ARS emails in the inbox that are received with in a few minutes

Joon_0-1673362530603.png

 

Joon_2-1673362654608.png

Joon_3-1673362724811.png

 

 

 

java.lang.NullPointerException: Cannot get property 'value' on null object
at com.saviynt.ecm.ReceiveMailService.getEmailToProcess(ReceiveMailService.groovy:862)
at com.saviynt.ecm.ReceiveMailService.readAndGetEmailOauth(ReceiveMailService.groovy:568)
at IncomingMailARSJob.execute(IncomingMailARSJob.groovy:160)
at org.quartz.core.JobRunShell.run(JobRunShell.java:199)

Joon
Regular Contributor II
Regular Contributor II

Thank you, Rushikesh

I found the root cause and fixed, and confirm that It works fine.

So much appreciate for your help !

Dave
Community Manager
Community Manager

Hi @Joon - To help others in the future who may have a similar problem, what was the root cause?

Joon
Regular Contributor II
Regular Contributor II

the root cause was the scope in graph api, i added all the permissions related to "mail" in application permission in graph api.

POP3/IMAP won't be working for my environment so I tried oAuth, and then it worked properly.

Thanks Dave!

Share screenshot of what permission has been added


Regards,
Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.

AS5278
Regular Contributor II
Regular Contributor II

Hi Joon.

Can you please share a screenshot of what permissions were added?. It would be of great help.

Thanks.

xurde

Joon
Regular Contributor II
Regular Contributor II

Hello Xurde,

It should be working with "Mail.ReadBasic.All".

Please try it. it seems taking around 10 mins after you granted Admin consent on the Graph API permission.

Joon
Regular Contributor II
Regular Contributor II

Also It should be Application permission