We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

Tasks are not created when User Update Rule is triggered

niklasfa
New Contributor II
New Contributor II

Hello Saviynt community,

I've created a couple of user update rules and simulated the execution of them by uploading a set of users via CSV. Trigger is set to "trigger when user is updated from import". I've attached a couple of conditions (username OR email OR first name OR last name is updated). The outcome should be update tasks related to the modified user(s).

After successfully uploading existing users via CSV, no tasks are created, also not after a few seconds or minutes.

I've repeated that a couple of times with the same result. In the log file I can see lines like:Line 1921 ..... Proceed to Import for records - \u003e [U01082301, TestChange, UserChange,

 

Line 1922 ..... test.user@example.com, Employee, admin, IT-Administrator, Berlin, Germany, Amigopod, , , Manager] : true\n","stream":"stdout","time":"2023-08-03T08:11:01.983681328Z"}"
user not found in map.. fetching..\n","stream":"stdout","time":"2023-08-03T08:11:01.983730735Z"}"

 

But in the end it seems to work:

 

Line 1968 .... Saving user data for username : U01082301\n","stream":"stdout","time":"2023-08-03T08:11:02.026254231Z"}"

 

I can also see the changed data in the user within Saviynt. I also attached the log file if you want to take a look into it.

Do you have any idea? Log is also attached. Please let me know if more information is required.

Kind regards,

Niklas

7 REPLIES 7

armaanzahir
Valued Contributor
Valued Contributor

Hi @niklasfa ,

 

Can you share the user update rule defiition? The next condition parameter for multiple or conditions should have an AND operand.

armaanzahir_1-1691057020319.png

 

Also, have you made sure you have ticked the check rules option on the user upload pop up.

armaanzahir_0-1691056810086.png

 

Thanks,

Armaan

Regards,
Md Armaan Zahir

Hello Armaan,

thanks for your reply. Here is my rule definition:

niklasfa_0-1691071294173.png

niklasfa_1-1691071312711.png

I've also selected "check rules" during user import.

Thanks,

Niklas

Is provisioning connection set for your Regress Security system?

 

Thanks,
Devang Gandhi
If this reply answered your question, please Accept As Solution and give Kudos to help others who may have a similar problem.

Hi @niklasfa ,

Are you able to see any rule under user's update history?


Pandharinath Mahalle(Paddy)
If this reply answered your question, please Accept As Solution to help other who may have a same problem. Give Kudos 🙂

armaanzahir
Valued Contributor
Valued Contributor

Hi @niklasfa ,

The rule appears to be fine. 

Try uploading a user and share the screenshot of the user update history for the rules run column.

armaanzahir_0-1691073685299.png

 

 

Thanks,

Armaan

Regards,
Md Armaan Zahir

rushikeshvartak
All-Star
All-Star

Does Reconciliation Field as username was added during import ?

rushikeshvartak_0-1691121986545.png

 

Does user have active application account ?


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

niklasfa
New Contributor II
New Contributor II

Thanks for your answers. I have configured it as follows and now it's working (active application account is necessary):

niklasfa_0-1691129732615.png