Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Dynamic child attributes do not refresh in user update form

New Contributor III
New Contributor III

I have a problem with child attributes in the user update form that you can set up in the global configurations under Identity Lifecycle. I already had a ticket with Saviynt, but they say this behavior is standard. However, end users would not expect it. 

We have an attribute called "division" as parent attribute. From there the user selects an office and expects that the address fields like street, postal code, city, etc. are populated based on a data set. 


In the user creation form it works fine. We just mapped all child attributes to the parent attribute division. However, if you want to edit an existing user, change the division attribute, the child attributes do not refresh with the new address. Saviynt told me that this is not intended since the attributes are already populated. Meaning, our use case of refreshing the attributes to a new value is not supported. 


Does anyone have the same use case? Any idea if it is possible to adjust the SQL query in the child attributes slightly to force the attribute to refresh with the new value in the division attribute? 





Hi @Stauber ,

It's the current functionality. Auto refresh wouldn't change child values when you have set to default and editable is unchecked. (This is only when you are saving the values in account table)

If you remove account column, auto refresh works even for default value.

I would suggest here to make child dynamic attribute - 'check editable on update' and make it 'mandatory'. In the child attribute drop down, only new filtered value will be present based on the parent dynamic attribute selection.


If you find the above response useful, Kindly Mark it as Accept As Solution and hit Kudos


Assuming value is single make it editable 

Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.

New Contributor III
New Contributor III

Great, solution found. Not quite ideal, but a good workaround.