Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Privileges selection not working

surajan
New Contributor III
New Contributor III

Hi,

I'm trying to onboard an application which has entitlements and specific roles for each entitlement. So, I figured entitlement privileges' would be a good solution to implement. I created the entitlement type and added a new attribute to privileges.

On the request page, I am able to select the entitlements but when I click on "select Privileges" I get the following error.

surajan_0-1717688646854.png

Here is the configuration for the privilege

surajan_1-1717688780180.png

any help is appreciated.

Thank you,

Rajan

6 REPLIES 6

Dhruv_S
Saviynt Employee
Saviynt Employee

Hi @surajan 

As per the screenshot, you are using Attribute_Config as ENTITLEMENT_BASED. Are you importing them from the target application along with entitlements?

It looks like you are creating the new privilege by giving some values in ENUM type. If you are creating your own privilege then you need to keep Attribute Config as USER-BASED.

Regards,

Dhruv Sharma

surajan
New Contributor III
New Contributor III

Hi Dhruv,

I see thank you. it works now. 

also I'm trying to pass this value through an api call. How do I reference this value in a json?

Dhruv_S
Saviynt Employee
Saviynt Employee

Hi @surajan 

Thank you for the update. Can you confirm if your 2nd question is related to the same issue. If yes -please provide more information. Otherwise, please create a new post with the relevant details and title. 

Regards,

Dhruv

surajan
New Contributor III
New Contributor III

Hi @Dhruv_S 

yes, this is related to the topic. The main reason for creating this entitlement attribute is to send this info via api call when user is requesting a new account. I need to be able reference this object in the AddAccessJSON so the request can go through.

 

Thank you,

Rajan

Dhruv_S
Saviynt Employee
Saviynt Employee

Can you try with ${attribute_name} where attribute_name is the name of the attribute you have created.

NM
Valued Contributor II
Valued Contributor II

Hi @surajan , were you able to reference it in the add access json?