Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Forum Posts

SNC not Updating for Update Account

Hi Team, we have configured the SNC parameter for Create account JSON and Update account JSON . For creation it is updating as expected but when update happen to the user account SNC value is not populating for the account. can anyone help us on this...

Chakritha_0-1715163741861.png
Chakritha by New Contributor
  • 299 Views
  • 19 replies
  • 0 kudos

Azure AD Remove Access Not working

Hello,We are intergating Azure AD with Saviynt. By following Azure AD Saviynt documentation Azure AD team has given required permissions to service user, yet Remove Access (AADGroups) is not happening.AADGroup":{"headers":null,"message":{"error":{"co...

GSR by New Contributor III
  • 341 Views
  • 5 replies
  • 0 kudos

Usage Analytics - No Record Found

Hi,I have a similar issue as topic https://forums.saviynt.com/t5/application-access-governance/usage-analytics-no-record-found/m-p/70038After starting the usage analytics and filling in account & entitlement details the result is always the message: ...

DavidK by New Contributor III
  • 231 Views
  • 2 replies
  • 0 kudos

Google Analytics - Saviynt Published Connector

Regarding the Saviynt published connector for Google Analytics, which is found on the forums rather than the docs site:https://forums.saviynt.com/t5/community-sourced-integrations/google-analytics-integration-guide/ta-p/58306?_ga=2.263164108.13526880...

Brian by New Contributor II
  • 266 Views
  • 1 replies
  • 0 kudos

Usage Analytics - No Record found

Hello,We have the SAP S4 application integrated in Saviynt, and we want to run Usage Analytics report to understand the transaction usage details of users. We already imported the data in Saviynt from SWNCMONIINDEX table.Also, in the Data Analyzer, w...

Miha_1-1705057313701.png Miha_2-1705057530803.png Miha_0-1705057116992.png
Miha by New Contributor III
  • 1424 Views
  • 9 replies
  • 0 kudos

Resolved! SAV 4 SAV provisioning error

Hi Team,I have requested a SAV role through ARS in Saviynt using SAV4SAV connector. The tasks were generated but when I run WS retry job, I am getting error like below.{"auditDetails":{"call1":[{"headers":null,"statusCode":404,"description":null,"sta...

Issues found in Self Certification Campaign

I found following issues while testing Self Certification Campaign in Saviynt dev environment:1) I first launched the Self Certification Campaign in preview mode for myself. When I go to Step-2(Access Approval), I can see 12 records pending for revie...

Kaushik by New Contributor II
  • 1815 Views
  • 7 replies
  • 0 kudos

Resolved! Error if condition in workflow fails

Hi,I created a parallel workflow that starts with the following condition:"(entitlement.risk > 0) or (entitlement.privileged > 0) or (entitlement.CONFIDENTIALITY > 0)"If the condition is true the workflow works as intended but if the condition is fal...

DavidK_0-1706001003964.png
DavidK by New Contributor III
  • 706 Views
  • 2 replies
  • 0 kudos

Resolved! SAP Import Error "Unknown column 'DE' in 'field list'"

We have one SAP system where the Application data import is failing. Log shows the following errors:groovy.sql.Sql.withBatch Error during batch execution: Unknown column 'DE' in 'field list'"groovy.sql.Sql.handleError Rolling back due to: Unknown col...

ASA by Regular Contributor II
  • 1391 Views
  • 7 replies
  • 0 kudos

Resolved! Exception in converting responseText to Map

Hi Team ,I am facing Exception in converting responseText to Map while importing accounts from application. below is the account import json and able to call api successfully as per debug logs. Could you please check this.Account Import JSON:{"accoun...

Resolved! User Other attribute bottom section shows Startdate value instead of setting it on main Page

Hello team,I have set startdate value via Modify JSON in WD SOAP connector, it sets value but shows up in Other attributes page bottom instead of main page, I am not sure why this is happening and how to correct this?Can someone help me on this?Thank...

maheshbhoi_it_0-1702391279571.png
mbh_it by Regular Contributor II
  • 776 Views
  • 2 replies
  • 0 kudos

Unable to access dynamic attribute in Add Access JSOM and Add Access JSON is not getting called.

Hi TeamI am facing error while access the dynamic attribute in Add Access JSON. Dynamic Form Configuration: ADD Access JSON :{"call": [{"name": "Project","connection": "acctAuth","url": "<ENDPOINT URL>","httpMethod": "PUT","httpparams": "{\"shellnumb...

IAMVaibhav_1-1702277786624.png

Resolved! Account filter for Azure AD in Saviynt v23

Hi Team ,we are integrating Azure AD with saviynt . Through this integration we want to manage only employees account and exclude Admin account while import . we are using this account import filter in connection and its not working in v23. not(start...

Israr_0-1699892732521.png

AzureAD - entitlements with double-quotes

Hi all,Running into a few issues with those.  Can they be handled at all?Main issue I have is with the ENDPOINTS_FILTER.  Accesses import is throwing "Exception :: populateImportDataToEndpoints :: Error parsing JSON".I tried escaping the entitlement ...

flegare by Regular Contributor III
  • 491 Views
  • 1 replies
  • 0 kudos

Correct comments not getting updated in Saviynt Certifications Console during Campaign API call

I am calling following Saviynt User Manager Campaign API through Postman:https://<private>/ECM/api/v5/approverejectCampaignAccEntDetailsI am passing following input params:    {         "campaignid":"3", "certkey":"2",        "verifier":"aaaaaa",    ...

Kaushik by New Contributor II
  • 682 Views
  • 4 replies
  • 0 kudos

Email Template Link Issue

Hi Team,   We need to change the link in the below email template. But it is showing correctly in a validator, but incorrect in the Saviynt tool.    Regards, Aarthi Anand [This message has been edited by moderator to mask sensitive info from images]

AAnand by New Contributor
  • 774 Views
  • 1 replies
  • 0 kudos

saviynt app installation in snow

Hi Team,Installed the saviynt app in snow and able to import endpoints,entitlements,accounts into saviynt app in snow but to raise a request for application we need to create a dynamic attribute and that option is not showing in variables Could you p...

rinpatel_0-1693426162699.png
rinpatel by New Contributor
  • 536 Views
  • 1 replies
  • 0 kudos

Issue with Saviynt request to create AD group API

Hi Team, When we try to create a AD group from postman it doesnot and displays an error message that  "msg": "entitlementType cannot be null or blank", even though the entitlement type is not empty. Please see the attached screenshot.   Can someo...

Resolved! Exclude Apllication owner from self certification in Application owner campaign

Hi Team,We have requirement to exclude Application owner from campaigns, we need to exclude the application owner's account in the campaign, so that app owner don't see their self account in the campaign.We were doing hardcoding the accountname in Ac...

Resolved! Campaign API call not returning all fields in response

I was testing Saviynt User Manager Campaign related APIs using Postman tool.I fired HTTP POST request https://<private>/ECM/api/v5/fetchCampaignDetails   with params= campaignId: 3 Following is sample response:{"msg": "successful","Total New Certific...

Kaushik by New Contributor II
  • 906 Views
  • 3 replies
  • 0 kudos

How to upload the SOD ruleset where the minimum value that has to be determined in runtime

Hello Team we have some min values in the SOD ruleset whose values are dynamically picked as they have * in them but that does not seem to be working in Saviynt as expected  For example --> There are field values such as BUKRS and for this field we c...

shubhangsinha__0-1690954673006.png

Resolved! Can't change query in analytics

If I go to "Analytics Configuration List", open a previously created SQL analytics and click "Edit", I can't see (and change) the SQL query in the analytics.I'm pretty sure this worked in the past. Can anyone tell what this might be depended on?If I ...

ASA by Regular Contributor II
  • 1196 Views
  • 7 replies
  • 0 kudos

Technical rule not accepting SAVCUSTOMQUERY::ev.entitlement_value in ${user.customproperty1}

Hi Team,We need to provision one or more entitlement as part of birthright based on values stored in CP1 of user.Ex: If CP1 of user is ABC01,ABC02,ABC05Then we need to provision entitlement ABC01,ABC02,ABC05. For this we are using below query in the ...

sandeepsingh_0-1689004593435.png

AD Connector - Replacement for groovy : com.saviynt

Hello everyone, We are currently in 3.11 in Production environment.We have below code in AccountNameRule for our AD connector. But in developement environment we are in 3.17, and we were made aware that com.saviynt is now deprecated and can't be used...

Romain_1-1685103900996.png
Romain by New Contributor
  • 1143 Views
  • 8 replies
  • 0 kudos

Error while creating account in AD - No signature

Hello, We are facing the following error when trying to provision account in AD. Error while creating account in AD - No signature of method: com.saviynt.ecm.services.SaviyntCommonUtilityService.generatePswd() is applicable for argument types: (null,...

KhaoulaD by New Contributor III
  • 680 Views
  • 3 replies
  • 0 kudos

Resolved! Microservice Job with HTTP Error 400

Hi,the Microservice Job in a new instance is failing with a 400 Bad Request:DEBUG jobs.MicroserviceJob - MicroserviceJob start @ Mon Mar 13 11:24:08 UTC 2023"DEBUG microservice.MicroserviceApiCallService - Inside apiCall() method.."DEBUG generic.Gene...

ASA_0-1678714433962.png ASA_1-1678714476765.png
ASA by Regular Contributor II
  • 1614 Views
  • 8 replies
  • 0 kudos

Salesforce - Substring in modify account json.

Hi Team,We tried to add substring function in modify account json in Salesforce out of the box connector.The substring function is not working. It is not giving any error but the data is not getting reflected as expected.{"Alias": "${user.firstname.t...

Lockedout uses and the requests

Hi,Requests for locked out users are being processing by Saviynt but not in the backend or target system as the user accounts are locked out. This is leading to a situation where Sav and the target systems are not in sync. After the Users accounts ar...

UmaSankar by New Contributor
  • 1383 Views
  • 4 replies
  • 0 kudos

Design Module for disconnected application

Hello! Does anyone know why the "FileImport" in the other application is gone missing? I know file import can be done through File Directory but we are presenting different options and the Design Module is doing well until the FileImport option is mi...

jezzanuena_0-1673236398928.png
jezzanuena by Regular Contributor
  • 523 Views
  • 1 replies
  • 0 kudos

Issue in Analytics Reports

Hi Team,We are facing error when we try to trigger the analytics report.Below is the screenshot for the error.Is there any configuration for this?Could you please help us in this.Regards,Varshitha

Varshi_Balaji_0-1661541553586.png