Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Service Account Workflow

Mortal
Regular Contributor
Regular Contributor

Working on the Service account workflow, when we request the service account in the managed service accounts, the request should go to the Owner for approval, which we select in the request form itself. So, do we need to pass any query in the custom assignment while selecting the owner?

And regarding the service account name rule mentioned in the document, is creating dynamic attributes for the name rule mandatory?

4 REPLIES 4

rushikeshvartak
All-Star
All-Star

If you want to send approval to owner selected on request form use below query in

select owneruserkey as 'userkey' from accountowners where accountkey = (select distinct REPLACE(raa.attribute_value,' ','') from request_access_attrs raa, ars_requests ar, request_access ra WHERE ar.REQUESTKEY = ra.REQUESTKEY and ra.REQUEST_ACCESSKEY = raa.REQUEST_ACCESS_KEY and ar.requestkey =${ARSREQUEST.id} and raa.ATTRIBUTE_NAME='Accountkey') and owneruserkey is not null

 

And regarding the service account name rule mentioned in the document, is creating dynamic attributes for the name rule mandatory?  - Its optional

Refer - https://forums.saviynt.com/t5/application-access-governance/service-account-integration-queries/m-p/...


Regards,
Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.

Mortal
Regular Contributor
Regular Contributor

Hi @rushikeshvartak ,

After assigning the workflow for service account the request is not getting created.
attaching the workflow ss for the reference.

Select user field should be custom Query in owners Approval block


Regards,
Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.

Mortal
Regular Contributor
Regular Contributor

The request is getting created and I can view it in request history but not in pending approval. The Assignee of that request is showing as null. PFA ss.

[This message has been edited by moderator to mask PII from an attached image]