We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

Oauth Email configured but save & test showing error CompactToken parsing failed error code: 800492

maheshbhoi_it
Regular Contributor
Regular Contributor

Hello Team,

I have configured SMTP on Fresh Environment, and save & test shows following error,  I suspect some permissions issue from Customer side however, customer denies same , I want to know the steps to resolve,. As far as I know , he configured SMTP from Azure. Error logs attached as well,

From error logs, I am sure its authentication problem, however need to educate customer with Specific steps to resolve this.

maheshbhoi_it_0-1701101307495.png

 

"2023-11-27T16:06:43.732+00:00","ecm","","","","2023-11-27T16:06:43.138498527Z stdout F 2023-11-27 16:06:43,138 [http-nio-8080-exec-40] DEBUG services.HttpClientUtilityService - timeout validated for api..."
"2023-11-27T16:06:43.732+00:00","ecm","","","","2023-11-27T16:06:43.138502327Z stdout F 2023-11-27 16:06:43,138 [http-nio-8080-exec-40] DEBUG services.HttpClientUtilityService - got response for api..."
"2023-11-27T16:06:43.732+00:00","ecm","","","","2023-11-27T16:06:43.138506227Z stdout F 2023-11-27 16:06:43,138 [http-nio-8080-exec-40] DEBUG services.EmailerService - StatusCode: 401"
"2023-11-27T16:06:30.731+00:00","ecm","","","","2023-11-27T16:06:29.844104836Z stdout F 2023-11-27 16:06:29,843 [http-nio-8080-exec-19] DEBUG services.HttpClientUtilityService - called executePostRequestWithHeaders for api..."
"2023-11-27T16:06:30.731+00:00","ecm","","","","2023-11-27T16:06:29.844131737Z stdout F 2023-11-27 16:06:29,843 [http-nio-8080-exec-19] DEBUG services.HttpClientUtilityService - after calling executeRequestWithHeaders for api..."
"2023-11-27T16:06:30.731+00:00","ecm","","","","2023-11-27T16:06:29.844152437Z stdout F 2023-11-27 16:06:29,844 [http-nio-8080-exec-19] DEBUG services.EmailerService - StatusCode: 401"
"2023-11-27T16:06:30.731+00:00","ecm","","","","2023-11-27T16:06:30.00193217Z stdout F 2023-11-27 16:06:30,001 [http-nio-8080-exec-5] DEBUG domain.EcmConfigController - Inside create params = [controller:ecmConfig, action:create, id:MAILCONFIG_OAUTH]"
"2023-11-27T16:06:30.731+00:00","ecm","","","","2023-11-27T16:06:30.034596966Z stdout F 2023-11-27 16:06:30,034 [http-nio-8080-exec-5] DEBUG domain.EcmConfigController - Inside basicSendEmail params = [:]"
"2023-11-27T16:06:30.731+00:00","ecm","","","","2023-11-27T16:06:30.057816077Z stdout F 2023-11-27 16:06:30,057 [http-nio-8080-exec-5] DEBUG domain.EcmConfigController - Inside OauthSendEmail params = [:]"
"2023-11-27T16:06:30.731+00:00","ecm","","","","2023-11-27T16:06:30.110657357Z stdout F 2023-11-27 16:06:30,110 [http-nio-8080-exec-5] DEBUG domain.EcmConfigController - Inside OauthRecieveEmail params = [:]"
"2023-11-27T16:06:29.731+00:00","ecm","","","","2023-11-27T16:06:29.700427032Z stdout F 2023-11-27 16:06:29,700 [http-nio-8080-exec-19] DEBUG services.HttpClientUtilityService - before calling executeRequestWithHeaders for api..."
"2023-11-27T16:06:29.731+00:00","ecm","","","","2023-11-27T16:06:29.700459232Z stdout F 2023-11-27 16:06:29,700 [http-nio-8080-exec-19] DEBUG services.HttpClientUtilityService - isFipsEnabled = false"
"2023-11-27T16:06:29.731+00:00","ecm","","","","2023-11-27T16:06:29.700481532Z stdout F 2023-11-27 16:06:29,700 [http-nio-8080-exec-19] DEBUG services.HttpClientUtilityService - getHttpClient - sslParams : null"
"2023-11-27T16:06:29.731+00:00","ecm","","","","2023-11-27T16:06:29.700487132Z stdout F 2023-11-27 16:06:29,700 [http-nio-8080-exec-19] DEBUG services.HttpClientUtilityService - getHttpClient - proxyParams : null"
"2023-11-27T16:06:29.731+00:00","ecm","","","","2023-11-27T16:06:29.700490632Z stdout F 2023-11-27 16:06:29,700 [http-nio-8080-exec-19] DEBUG services.HttpClientUtilityService - getHttpClient - sslSocketFactory : null"

 

Kindly advise.

Thanks
Mahesh

 

 

 

9 REPLIES 9

pruthvi_t
Saviynt Employee
Saviynt Employee

Hi @maheshbhoi_it ,

Greetings.

We have similar issues reported with exactly same error. This is an issue with token generated on the customer end. Please ask the customer to regenerate token and use it , it should fix the issue. 

Thanks,


Regards,
Pruthvi

rushikeshvartak
All-Star
All-Star

This error message "CompactToken parsing failed with error code: 80049217" generally occurs when the token used is invalid.

https://learn.microsoft.com/en-us/answers/questions/1222032/compacttoken-parsing-failed-with-error-c...


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

maheshbhoi_it
Regular Contributor
Regular Contributor

Hi Rushikesh,

Thanks for your inputs,

I have pointed this to customer and awaiting for details to rectify the authentication.

Thanks once again for your valuable response,

Thanks

Mahesh

Manu269
All-Star
All-Star

@maheshbhoi_it we encountered this issue recently and post discussion with saviynt we were notified that this was due to invalid token provided by customer.

Requested new token and it worked.

Regards
Manish Kumar
If the response answered your query, please Accept As Solution and Kudos
.

maheshbhoi_it
Regular Contributor
Regular Contributor

Hi Manish/Rushikesh,

Thanks for the details, I have asked them and they shared me another secret key which still did not work, I shared the configurations steps which saviynt has given at following link and they added those permissions, however it did not work.

https://docs.saviyntcloud.com/bundle/EIC-Admin-v23x/page/Content/Chapter06-EIC-Configurations/Settin...

 

Kindly let me know if there is a document for Azure which has all steps as Customer looks to be unaware of what is missing, and I have not operated Azure portal for same.

Thank you

Mahesh

Can you trying restarting server 


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

maheshbhoi_it
Regular Contributor
Regular Contributor

Hi Rushikesh,

I restarted as well, this still did not work and I am sure this is something to do with authentication from Customer side, however looking for exact steps to do the complete SMTP Oauth configs.

 

Thanks

Mahesh

Try logging from postman 

https://login.microsoftonline.com/common/oauth2/token


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

maheshbhoi_it
Regular Contributor
Regular Contributor

Hi Rushikesh,

I tried following on last friday Postman login and was able to find errors and point solutions to customer which helped us fix this, thanks for your constant inputs.

login to https://graph.microsoft.com/.default and generate Oauth token., this one I used.

Thanks

Mahesh