We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

Not able to change password from API

FranciscoS
New Contributor III
New Contributor III

Dear community,

We have created an user in Saviynt with the aim to be used with API to change user passwords.

This user has been set the password by an admin account through API and we have set the localauthenabled and passwordexpired properties with CustomQuery job as follows:

FranciscoS_0-1698093913740.png

A SAV role has been added to the user with the following endpoint access:

FranciscoS_1-1698093969970.png

This user is able to call the login endpoint and get a Bearer token. When trying to call the changePassword endpoint ({{url}}/ECM/{{path}}/changePassword) using this valid token and the body with the username and password of another user, I get the following response:

FranciscoS_2-1698094086145.png

We do not know what is happening since this is not the expected response. We have compared this user to the user who was able to set the password for this same user and everything looks right. Even I set the same SAV Role and I get the same response.

I am stuck with this and I need your help, please.

Could you be so kind to help me?

Kind regards,

Francisco J.

[This message has been edited by moderator to mask url]

2 REPLIES 2

rushikeshvartak
All-Star
All-Star

Please share postman screenshot. Its working for me

rushikeshvartak_0-1698113968425.png

 


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

Hello Rushikesh,

Thanks for your prompt answer. The screenshot:

FranciscoS_0-1698131653830.png

No variables have been set apart from username and password. They are not actually needed. This same call is working fine with the other user that we have to set passwords (that one which was used to set the password for this changePassword service acccount).

Also I want to note that when trying to call any other endpoint, for example /getUser, I am getting the same 200 OK response: "Sign in to your account"...