We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

Default Authentication Type in SMTP settings.

Saviynt_Savvy
Regular Contributor
Regular Contributor

Hi All,

We have 2 tenants (sandbox and Dev) of the same version (23.9).
We have configured the SMTP in both Tenants where the Authentication Type is chosen as "Oauth".
But whenever we access the SMTP settings we see the Authentication Type as "Oauth" by default in the "Sandbox" environment and the Authentication Type as "Basic" by default in the "Dev" environment.

Sandbox Environment:

Saviynt_Savvy_0-1706182449766.png

Dev Environment:
Saviynt_Savvy_1-1706182519412.png

The EmailHistoryJob in the Sandbox environment is running successfully but in the Dev environment the EmailHistoryJob is job failing and in the Job History Details showing the error under the Response column as "Failure: Email Configuration not defined".

Saviynt_Savvy_2-1706182662354.png

I need to know the information regarding,
1.  What is the reason that the SMTP settings in Dev environment showing the authentication type as        "Basic" by default instead of "Oauth"?
2. Is that is the reason for the EmailHistoryJob failure in the Dev environment?

Thanks & Regards,
Saviynt Savvy

4 REPLIES 4

rushikeshvartak
All-Star
All-Star

Its just dropdown. Main reason of failure is smtp configuration are not set


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

Hi @rushikeshvartak ,
Thank you for the response.

We have configured the SMTP.

Saviynt_Savvy_0-1706202434982.png

And tested the Connection.

Saviynt_Savvy_2-1706202680149.png

Able to receive the Mail also.

Saviynt_Savvy_1-1706202513272.png
Thanks & Regards,
Saviynt_Savvy.

Hi @rushikeshvartak ,

As in my previous reply, I am able to send the mail and able to receive it.
But still when I go to Settings-->SMTP Configuration, again I see the Authentication Type as "Basic" by default (in dev tenant).
Now again, I am not able send the mail that I've configured in Manager level approval Workflow.
I assume that because of this SMTP configuration getting stucked at Auth type as "Basic" (although already have configured it "Oauth"), I'm not able to send the mail.
Again I need to select the "Oauth" from the drop-down to see the configurations I've given.
As mentioned in my post, In Sandbox environment, "Oauth" is remained as the Authentication Type by default.
Could you please suggest why the authentication type is not "Oauth" by default, in Dev enviornment.

Thanks & Regards,
SaviyntSavvy

Check below from data analyzer in both instance 

rushikeshvartak_0-1706766580882.png

 


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.