Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Create User - How to stop default "systemUserName" generation logic?

GauravJain
Regular Contributor
Regular Contributor

Hi

We noticed that while creating a user from Saviynt UI, it generates a default "systemUserName" for that user by default. We have to stop this default behavior but couldn't find any relevant references in Saviynt documentation so require an immediate help.

Please let me know if you require any further inputs from my end.

Thanks

Gaurav

12 REPLIES 12

Raghu
Valued Contributor III
Valued Contributor III

Hi @GauravJain 

Please chck Global config->Identityfy lifecycle->in below

Raghu_0-1714629679171.png

 


Thanks,
Raghu
If this reply answered your question, Please Accept As Solution and hit Kudos.

GauravJain
Regular Contributor
Regular Contributor

Hi @Raghu thanks for your revert. we have already verified this and there is no rule setup here in our test environment.

SystemUserName.JPG

Raghu
Valued Contributor III
Valued Contributor III

if want your  logic there need include , other-wsie system will take default username


Thanks,
Raghu
If this reply answered your question, Please Accept As Solution and hit Kudos.

GauravJain
Regular Contributor
Regular Contributor

No, it was not taking default as username. Rather its taking first character of "FirstName" + LastName.
Is there a way we can stop this default behaviour as we are using "systemUserName" to store users employee id in import process - the reason for doing this is Saviynt do not have index on employeeID field which is our RECON field?

Hi @GauravJain 

I tried to replicate the issue. It looks to be a bug. I will check and let you know. 

I tried using below workaround to create blank systemusername.

substring(users.firstname,-1,-1)

Regards,

Dhruv Sharma

GauravJain
Regular Contributor
Regular Contributor

thanks @Dhruv_S . please confirm if its a bug. i think we cant have any pre-assigned value to "systemUserName" . you can check my earlier reply to Raghu.

Hi @GauravJain 

I have confirmed this internally. This is expected behavior. There is a default systemusername generation logic if systemusername generation rule is not configured. 

Regards,

Dhruv Sharma

GauravJain
Regular Contributor
Regular Contributor

Thanks @Dhruv_S . it looks like i can update this value once assigned by Saviynt which has resolved my issue for time being. is there a way we can disable this default configuration?

But, is this default behavior same in all different ways of user creation process like creating a user from csv file upload or by using an API end point? I have not tried it out but assuming behavior should be same.

Hi @Dhruv_S can you please revert on my last post?

Hi @GauravJain 

The behavior is same across all the three ways. Systemusername get generated by default with no rule configured.

1. User created from UI

2. User created from API

3. User created from CSV Import with generate system username selected as yes

This configuration cannot be disabled for UI/API. It can be disabled for the csv import.

Regards,

Dhruv Sharma

GauravJain
Regular Contributor
Regular Contributor

Thanks @Dhruv_S for your quick revert. So, the default behavior is not consistent across various options.

You can go with workaround


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.