We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

Connection Failure via WinConnector

Aashish-Handa
Regular Contributor
Regular Contributor

Hi Team,

We are using an OOTB WINCONNECTOR connection type to connect to a Windows IIS server from Saviynt. We have followed the prerequisite steps to deploy the Saviynt App on the IIS Server using the following documentation site: 

Understanding the Integration between EIC and Windows Server (saviyntcloud.com)

There are a couple of things to be brought up while these configurations were done on the IIS server:

  • While trying to Connect as> under Basic Settings, we were able to connect as the administrator, however the doc mentions it as Application user (pass-through authentication). When doing this, we get a authorization warning saying that Cannot verify access to the path. (However, we have provided read access to Everyone).
  • While configuring OutBound rules, we are not able to see URL rewrite page in the IIS section, hence couldn't complete this step.

Now, while trying to save the connection in Saviynt with the URL: http://<hostname>/SaviyntApp/PS/ExecutePSScript,  which is the only required attribute, we are getting a connection failed error. PFB the logs:

{"log":"2023-12-04 07:34:01,442 [http-nio-8080-exec-25] DEBUG services.WindowsConnectorService - Enter testConnection\n","stream":"stdout","time":"2023-12-04T07:34:01.442436743Z"}
 
2023-12-04T13:04:02+05:30-ecm-{"log":"2023-12-04 07:34:01,445 [http-nio-8080-exec-25] ERROR services.WindowsConnectorService - Exception \n","stream":"stdout","time":"2023-12-04T07:34:01.445356447Z"}
 
2023-12-04T13:04:02+05:30-ecm-{"log":"org.codehaus.groovy.grails.web.converters.exceptions.ConverterException: Error parsing JSON\n","stream":"stdout","time":"2023-12-04T07:34:01.445379162Z"}
 
2023-12-04T13:04:02+05:30-ecm-{"log":"\u0009at grails.converters.JSON.parse(JSON.java:292)\n","stream":"stdout","time":"2023-12-04T07:34:01.445392076Z"}
 
2023-12-04T13:04:02+05:30-ecm-{"log":"\u0009at com.saviynt.ecm.services.WindowsConnectorService.testConnection(WindowsConnectorService.groovy:1460)\n","stream":"stdout","time":"2023-12-04T07:34:01.445396775Z"}
 
2023-12-04T13:04:02+05:30-ecm-{"log":"\u0009at com.saviynt.ecm.integration.ExternalConnectionCallService.testExternalConnection(ExternalConnectionCallService.groovy:596)\n","stream":"stdout","time":"2023-12-04T07:34:01.445400704Z"}
 
2023-12-04T13:04:02+05:30-ecm-{"log":"\u0009at com.saviynt.ecm.utility.domain.EcmConfigController$_closure21.doCall(EcmConfigController.groovy:765)\n","stream":"stdout","time":"2023-12-04T07:34:01.445404397Z"}
 
2023-12-04T13:04:02+05:30-ecm-{"log":"\u0009at grails.plugin.springsecurity.web.filter.GrailsAnonymousAuthenticationFilter.doFilter(GrailsAnonymousAuthenticationFilter.java:53)\n","stream":"stdout","time":"2023-12-04T07:34:01.445408085Z"}
 
2023-12-04T13:04:02+05:30-ecm-{"log":"\u0009at com.saviynt.webservice.SaviyntRestAuthenticationFilter.doFilter(SaviyntRestAuthenticationFilter.groovy:155)\n","stream":"stdout","time":"2023-12-04T07:34:01.4454112Z"}

Unable to figure out whether we are missing something or is it due to the pass through authenctication. Request assistance on the above.

[This message has been edited by moderator to disable hyperlink to an URL]

4 REPLIES 4

DixshantValecha
Saviynt Employee
Saviynt Employee

Hi @Aashish-Handa,

We are checking on this and we will keep you posted.

FraZ
New Contributor
New Contributor

We tried installing the IIS server again with an SSL certificate and the connection was established.

Thanks

I understand that you're facing issues with the Saviynt WINCONNECTOR connection to a Windows IIS server. Based on the information you've provided and some additional resources, here are a few suggestions that might help:

1. **Connect as Application User**: The documentation suggests using an Application User for pass-through authentication. If you're getting an authorization warning, it might be due to insufficient permissions. Even though you've provided read access to 'Everyone', there might be other permissions required. You could try using a service account with the necessary permissions instead of 'Everyone'.

2. **URL Rewrite Page**: If you're not able to see the URL rewrite page in the IIS section, it could be because the URL Rewrite Module is not installed. You can download and install it from the official Microsoft website.

Aashish-Handa
Regular Contributor
Regular Contributor

We tried installing the IIS server again with an SSL certificate and the connection was established.

Thanks