Research bar in Entitlements page not working

New Contributor
New Contributor
I'm implementing Saviynt IGA, on-premises, version
When using any other Sav role other than the Admin role, the research bar in the Entitlements page does not work. However, if i use the advanced search that works correctly. In all other pages of the Identity Repository, both the advanced and research bar work properly.
To ensure that this was not related to any permissions that may be missing i used a copy of the admin role and added it to all of the connectors. The issue persisted.
Has anyone experienced this issue?
Thank you!

Saviynt Employee
Saviynt Employee

Can you please add details or screenshots around what is not working and what all access does your sav role have.

Saviynt Employee
Saviynt Employee

I appreciate you reaching out to the Saviynt forums.

For issue with the research bar in the Entitlements page of Saviynt IGA version

To troubleshoot the issue, you could try the following steps:

  1. Check the Saviynt logs for any errors related to the research bar on the Entitlements page.
  2. Verify that the necessary permissions are granted to the role you're using to access the Entitlements page.
  3. Try accessing the Entitlements page using a different browser or clearing the cache of your current browser.
  4. Check if there are any customization or configuration changes made to the Entitlements page that could be causing the issue.

Hi, I leave below some answers that i hope provide a bit more detail into this issue.

1. The logs show no errors when i use the research bar, the query seems to be properly run. The results are simply not shown. I'll leave the logs attached to this post. 

In the "Ent_search_logs" file, you can find the logs corresponding to, using the admin copy role, opening the entitlements page, then searching "dl_" in the search bar (the number of results displayed did not change).  In the "Ent_search_logs_admin", you can find the logs corresponding to, executing the same actions but using the original admin role, here the results displayed changed to 1,225 instead of the original 5,328 results. Comparing the two I can see two lines which do not appear when using the admin role.

"endpointlist in entTypesAllowed() : []" and " endpointlist size in entTypesAllowed() : 0"

However, I do not know where the allowed entitlement types can be defined. I have already added the admin copy role to all connectors and selected All in the Sav role "Access to Endpoints" attribute.

2. I'm using a role which has all the same permissions as admin, no more permissions are available to add to the role in the Access page. Attached i'm leaving an export of the permissions this role has. Furthermore, I believe this is not a privilege related issue because when using the advance search, the results are correctly shown. 

3. I did so and the same behavior occurred.

4. No customization was performed in this page and the search bar works correctly when using the admin role.

Thank you for your help! @DixshantValecha @ParitaSavla 

Saviynt Employee
Saviynt Employee

From the logs shared looks like it is checking for the logged in user as the owner of the entitlement and then showing up the list of such entitlements. The search should work fine as long as for an entitlement as long as you are the owner of the entitlement. 

Please let me know if this helps.

Hi @ParitaSavla,

Thank your for the feedback!

I tested that by adding my test user as the Rank 1 owner of one of my entitlements and even when searching only for that specific entitlement value the page is still not displaying the search results. 

Is there any specific configuration that could be making Saviynt check the entitlement owner that i can disable?

I am implementing an older version of Saviynt and the entitlement's owner functionality is not working properly so i guess that might be impacting this search.

Saviynt Employee
Saviynt Employee

Are you logged in as that test user and then when you go to the entitlements list page are you able to see the entitlement_Value in the entitlement list page. 

If yes and then when you run the search, is it still not showing up?

If so please can you please also get the browser logs using developer tools.

I can help outline the expected behavior where if the logged in user has a non admin role, then he needs to be an owner to view the entitlement and the search would work as expected.