Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Random password not working during AD account creation

SaiKiran
New Contributor
New Contributor

User account is created in AD without any issues. When checked the Password Last set in AD it is showing as Not set. We have kept SETRANDOMPASSWORD as true in our AD connection and added the below in create account JSON.

"pwdLastSet": "0",
"userPassword": " ${randomPassword}"

5 REPLIES 5

Saathvik
All-Star
All-Star

Remove userPassword mapping in CREATEACCOUNTJSON as connector itself will handle assigning password when you use SETRANDOMPASSWORD to true. Also please make sure that you have password policy assigned to security system with REGEX or atleast set password policy at connection level so that a randompassword can be generated.

 

Also if randompassword you are setting is not one time(meaning user don't have to change the initial password on first time login) then change pwdLastSet to -1 instead of 0


Regards,
Saathvik
If this reply answered your question, please Accept As Solution and give Kudos to help others facing similar issue.

Hi Saathvik,

We already set the password policy at the connection level.

 

Did you try other suggestions?


Regards,
Saathvik
If this reply answered your question, please Accept As Solution and give Kudos to help others facing similar issue.

Hi Saathvik,

We have updated the password policy with Regex and assigned the password policy to security system. we have updated the regex as below.

(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])

But still in AD password last set is showing as Not Set. Our requirement is to generate a random password during account creation.

SaiKiran
New Contributor
New Contributor

Hi Saathvik,

Can you please help on this issue. we are trying with below regex

(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[~!@#$%^&?]).{8,12}