We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

Base Count not working as expected in Analytics

haardik_verma
Regular Contributor
Regular Contributor

Hi,

We have a use case where we do not want to send repetitive data in the consecutive scheduled analytics report emails.

I came across "Base Count" feature which promised to solve the exact case.

But unfortunately, it does not seem to be working for me. Please share your inputs and suggestions if I am doing something wrong or missing anything.

As per the documentation in Creating Elasticsearch-based Analytics Controls (Version 2) using SQL Query (saviyntcloud.com)

haardik_verma_0-1704264660772.png

 

My Analytics details:

Query: select username from users where username like '%reuse%'

Risk: Low

Base Count: 1

Number of History to Keep: 10 (Archival disabled)

Where do you want to save your data?: Save Data is checked

 

The above query in data analyzer had 14 results. So the analytics on its first run gave 14 results. I then modified 1 new test user so that the query now gives 15 results in data analyzer.

The expectation was that the Analytics will now give only 1 entry in the result but it gave 15.

I then modified the analytics with below

Base Count: 2

Number of History to Keep: 5 (Archival disabled)

After this, I modified few more test users and the query in data analyzer kept on increasing the number of results but the analytics gave 0 results.

haardik_verma_1-1704264961132.png

 


Thanks & Regards,
Haardik Verma
9 REPLIES 9

rushikeshvartak
All-Star
All-Star

Does query returns results in data analyzer


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

yes,

The query returns data in Data Analyzer and the data keeps on increasing as I keep modifying new test users.

# RunResult in Data AnalyzerResult in Analytics
11414
21515
3160
4180

After the 2nd run, the base count was modified from 1 to 2 and the history to keep was modified from 10 to 5


Thanks & Regards,
Haardik Verma

You can date filter to limit the data 


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

Sorry but the actual use case is not that chronologically incremental.

We will need Base Count feature to work


Thanks & Regards,
Haardik Verma

If you have selected to save the results in the file system, then you will not be able to see the conflict details on User Interface. In that case, the Total Conflict count will be displayed as zero and you will only have the option to download the file and view the results.

Once you run the Analytics and go to history for that analytics, you will see the total count as 0. However, there will be a download option available beside the total count value. You should be able to access your report through download.

 

click save data to elastic search


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

Hi @rushikeshvartak 

These are the only 3 options I see

haardik_verma_0-1704294566546.png

Also, I do not see download option in history page; only delete.

haardik_verma_1-1704294688338.png

 


Thanks & Regards,
Haardik Verma

Try recreating analytics


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

created new analytics.

Base count 2, history to keep 5

On the first run, analytics gave 20 results (same as in data analyzer)

after this, I modified the data and now data analyzer gave 21 results but analytics gave 0 results


Thanks & Regards,
Haardik Verma

Just click - save to file


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.