Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

we are username already exists but there is username present.

srinath
Regular Contributor
Regular Contributor

While we are creating any user using ARS form, we are getting username already exists. We are using global configuration to generate username not with ARS form

srinath_0-1716298899125.pngsrinath_1-1716298932605.png

 

No Error logs

srinath_2-1716298974427.png

 

 

21 REPLIES 21

NM
Valued Contributor
Valued Contributor

Hi @srinath, any approval flow configured?

srinath
Regular Contributor
Regular Contributor

@NM No there are no workflow for user creation

pmahalle
All-Star
All-Star

@srinath ,

Can you share the dynamic attribute configuration you have created on ARS form for username field.


Pandharinath Mahalle(Paddy)
If this reply helps your question, please consider selecting Accept As Solution and hit Kudos 🙂

srinath
Regular Contributor
Regular Contributor

@pmahalle  There is no dynamic attribute configured for username as username will generate by Global configuration setting

 

NM
Valued Contributor
Valued Contributor

@srinath , use advance config and check once..

srinath
Regular Contributor
Regular Contributor

It worked earlier with same configuration perfectly

  • Please share logs.
  • validate if username exists in request_Access_attrs table

Regards,
Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.

Hi @rushikeshvartak ,

There are no logs as it is not allowing to create users just giving Security manager username exists already. And we are not using any dynamic attribute to generate username, we are using same global configuration logic to generate username. 

Still there will be entry in request_Access_attrs table


Regards,
Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.

Hi @rushikeshvartak ,

I searched in the request_access_attrs table but i dont anything with the value. Do i need to search for something else on this else do i have the query

@srinath : Rushi asked to check if username with combination you have is already present in request_Access_attrs table. 

Also you do see any request getting created for error?

Did any user with same firstname and lastname already exist in system?

What is the username you are expecting as output(as you have multiple rules configured)?

Do you see any user with same name already exists in username or request_Access_attrs table?


Regards,
Saathvik
If this reply answered your question, please Accept As Solution and give Kudos to help others facing similar issue.

srinath
Regular Contributor
Regular Contributor

Hi @Saathvik ,

I understand, but in request_access table what field i need to look for? As mentioned we cannot find anything on logs as the request is still not completed and we are only receiving popup stating username already exists. just FYI, we are not using any dynamic attribute for username. This is autogenerated by Global configuration.

We are unable to create any users, initially worked as expected. Today some of the administrator change username logic and reverted back this is only one change.

No, we do not have any user firstname or last name matching, even user name generation rule depends on the condition as below 

srinath_0-1716317307429.png

 

srinath_1-1716317323098.png

 

there are default attributes get pushed to request_Access_attrs table even though there are no dynamic attribute 


Regards,
Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.

Just an example i am entering firstname as orange, lastname as apple still i am getting same error 

srinath_0-1716365408028.png

[This message has been edited by moderator to mask sensitive info]

@srinath ,

You are getting this error for specific first name, last name or for anything you provided on form?


Pandharinath Mahalle(Paddy)
If this reply helps your question, please consider selecting Accept As Solution and hit Kudos 🙂

srinath
Regular Contributor
Regular Contributor

Hi @pmahalle ,

After filling the form and submitting the request then this error is occuring. Moreoever i already verified there is no firstname/lastname or username exists on the saviynt system

@srinath  My question was, irrespective of what value you are providing in first and last name fields you are getting this error on submission?


Pandharinath Mahalle(Paddy)
If this reply helps your question, please consider selecting Accept As Solution and hit Kudos 🙂

srinath
Regular Contributor
Regular Contributor

Hi @pmahalle , exactly

Please share logs and console logs from browser 


Regards,
Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.

Hi @rushikeshvartak  Here is the logs as requested

srinath
Regular Contributor
Regular Contributor

Issue got resolved. We identified there was existing username with null value and this caused the issue. Thanks everyone for providing there inputs.