We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

User Response Path - Unexpected character (S) at position 1 error in logs

samarth
New Contributor II
New Contributor II
Please see the snippet of logs attached. I am making a GET call via REST connector and the response is in the Concert logs.PNG

following format. 
 
[
{
"PersonId":111111,
"HashId":null,
"PSName":"Binney,GeorgePatrick",
"FirstName":"George",
"LastName":"Binney",
"MiddleName":"P",
"PreferredFirstName":null,
"PreferredLastName":"",
"Title":null,
"BirthDate":null,
"Gender":null
}
]
 
Am I seeing this error because the JSON response starts with "["? How can I resolve this issue? Is this a user response path problem? Can you help me identify the correct user response path?
Please see the snippet of logs attached. I am making a GET call via REST connector and the response is in following format. 
 
[
{
"PersonId":111111,
"HashId":null,
"PSName":"Binney,GeorgePatrick",
"FirstName":"George",
"LastName":"Binney",
"MiddleName":"P",
"PreferredFirstName":null,
"PreferredLastName":"",
"Title":null,
"BirthDate":null,
"Gender":null
}
]
 
Am I seeing this error because the JSON response starts with "["? How can I resolve this issue? Is this a user response path problem? Can you help me identify the correct user response path?
 
 
Concert logs.PNG
5 REPLIES 5

SB
Saviynt Employee
Saviynt Employee

Can you share the JSON you are using.


Regards,
Sahil

samarth
New Contributor II
New Contributor II

JSON below. I have tried and test variety of JSON paths. Also listing them below -

  • ""
  • "$.*"
  • "$*"
  • "$"
  • "*"
  • "[]"
  • "[*]"
  • "$.[*]"
  • "$[*]"

JSON:

{
"connection": "Concert",
"successResponses": {
"statusCode": [200, 201, 202, 203, 204, 205]
},
"url": "https://concertdatatest.abc.com/persons",
"httpMethod": "GET",
"httpHeaders": {
"Authorization": "Basic _________________________________"
},
"userResponsePath": "[]",
"colsToPropsMap": {
"username": "TWId#~char",
"employeeid": "TWId~#~char",
"firstname": "FirstName~#~char",
"statuskey": "isActive~#~char",
"customproperty21": "CreatePersonID~#~char",
"customproperty23": "ISFGOwned~#~char",
"customproperty24": "JobCategory~#~char",
"customproperty25": "IsPrimary~#~char"
}
}

SB
Saviynt Employee
Saviynt Employee

Can you define "userResponsePath": "" and then try.


Regards,
Sahil

samarth
New Contributor II
New Contributor II

I did that. No results. 

SB
Saviynt Employee
Saviynt Employee

Can you share the log for the above test.


Regards,
Sahil