We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

Unable to setup SFTP connector "get Config from Service" dropdown is not fetching SFTP connector cla

Diptansu1
Regular Contributor
Regular Contributor
Hello Team , 
 
While setting up SFTP connector in our dev tenant.Needed to run below steps :
Diptansu1_2-1685534339212.png
 
But for our case unable to fetch connector class rather its coming as below (no connector class is coming in dropdown)
 
Diptansu1_3-1685534367450.png
 
Please suggest.

 

7 REPLIES 7

sudeshjaiswal
Saviynt Employee
Saviynt Employee

Hello @Diptansu1,

Enable Microservices to view the Enhanced Connector Framework parameter while creating a connection type in EIC.
For assistance, please raise a Freshdesk ticket to enable the microservice.

Thanks,

For Ref :- 
https://docs.saviyntcloud.com/bundle/SFTP-Certified-v23x/page/Content/Configuring-the-Integration-fo... 

Hello , 

I have enabled this option . After this asper documentation below steps should be executed 

Diptansu1_0-1685948299440.png

But for our case in this dropdown SFTPConnector::1.0 this is not coming only below is showing

 

Diptansu1_1-1685948365839.png

That's the issue . Please suggest.

sudeshjaiswal
Saviynt Employee
Saviynt Employee

Hello @Diptansu1

The user specified under the username must be associated with an SAV role with the privileged access feature, and could you please check the user have all the privileges?
If the credentials of the system admin user are changed, ensure that the same credentials are updated in the MS Credentials parameter in Microservice Configurations and then restart the application.


Thanks,

Thanks for responding back . We are using user with ROLE_ADMIN privilege. But outcome is same for example I am having ROLE_ADMIN access tried with same but still no change in dropdown , again given SupportAgent1 id  to ROLE_ADMIN and specified in microservices config . But same result . 

Note: Restarted all services after each changes in Microservices config.

sudeshjaiswal
Saviynt Employee
Saviynt Employee

Hello @Diptansu1,

Can you please check the logs, what error do you see in the logs?

Thanks,

I have raised a freshdesk ticket for that and i guess team has done the fix . Now i can see it under dropdown

sudeshjaiswal
Saviynt Employee
Saviynt Employee

@Diptansu1 Thanks For the confirmation!