Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

The user is not updated from the target system in the REST Connector

user228
New Contributor II
New Contributor II

The HCM system connected to Saviynt via REST Connector has some users with different statuses: one is inactive because those users have different contracts. When we migrated it to the Saviynt for the first time, it was migrated with 1 user with Inactive status, but when we tried to update it, it is not updating at all and we received the following error in the logs:

first :

DEBUG-Proceed to Import for records - >

then:

-DEBUG-Not Importing user - either username attribute not found or if the vendor is there then user doesn't have access to import the vendor

but the Import shows success status:

user228_0-1709024417946.png

although it doesn't recognise the users at all from the target system.

We tried to choose another reconciliation field as customproperty10, but still, nothing is updated... so, let's say a user has a different user name but the same customproperty10 and different status, so in this case we cannot import the user. and why we don't get an error in this case?

 

I found here the case: https://forums.saviynt.com/t5/identity-governance/importing-only-one-user-from-db-to-saviynt/td-p/44...

but our case is a bit different, because in the future, we would like to migrate those users with their active accounts and reconcile it it customproperty10.

 

Thank you!

 

4 REPLIES 4

naveenss
All-Star
All-Star

Hi @user228 

Can you please share the JSON used for the import? Also a sample postman response for this. 

Regards,
Naveen Sakleshpur
If this reply answered your question, please click the Accept As Solution button to help future users who may have a similar problem.

user228
New Contributor II
New Contributor II

Here is the JSON:

{
"connection": "acctAuth",
"url": "URL",
"httpMethod": "GET",
"httpHeaders": {
"Authorization": "${access_token}",
"Accept": "application/xml",
},
"userResponsePath": "path",
"colsToPropsMap": {
"username": "username~#~char",
"secondaryemail": "Secondemail~#~char",
"email": "email~#~char",
"customproperty10": "EmployeeId~#~char",
"phonenumber": "Mobilephone~#~char",
"lastname": "Lastname~#~char",
"departmentname": "departmentname~#~char",
}
},
"statuskey": {
"1": "A",
"0": "I"
},
"successResponses": {
"statusCode": [
200
]
}
}

 

maybe it has smth to do with the rights...

n1khil
New Contributor III
New Contributor III

Have you found anything on this? im facing similar error but with Saviynt for Saviynt connector, where we are updating username field with reconcile field as userkey

user228
New Contributor II
New Contributor II

sorry I don't know what happend, because we didn't really changedd anything but for some reason now the user gets updated with an import