Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Systemusername gets generated every time job runs

PratithShetty
New Contributor III
New Contributor III

Hi all,

We have Active Directory as a trusted system to create users. We are generating a systemusername with the logic to increment from C_500000000. 

The observation is that every time i run the userimport job ( CREATE AND UPDATE in job config) I see the systemusername gets updated again with a new value. Is this expected? 

How do i make sure the systemusername is generated only during user creation?

 

Note: I tried creating two jobs - one for create( rule on) and update ( rule off) . I observed that when the update job ran, it made the systemusername null. 

 

3 REPLIES 3

rushikeshvartak
All-Star
All-Star

Where is systemusername configured ? Global config/ preprocessor 


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

naveenss
All-Star
All-Star

Hi @PratithShetty can you pls share the system username rule config?

 

Regards,
Naveen Sakleshpur
If this reply answered your question, please click the Accept As Solution button to help future users who may have a similar problem.

PratithShetty
New Contributor III
New Contributor III

Hi All,

 

The issue is resolved as i removed the systemusername attribute from my MODIFYUSERJSON. 

 

Thanks