Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

SFTP Connector unable to fetch dropdown value from "get Config from Service"

AtrayeeDutta
Regular Contributor
Regular Contributor
Hi Team,
 
While setting up SFTP connector in our dev tenant we are unable to fetch connector class rather its coming as below (no connector class is coming in dropdown)
AtrayeeDutta_2-1688316571590.png

 

 
Below steps are already performed:
 
1 – From Admin > Admin Options > Admin Options reset password for systemadmin account
 
2 – Create a customquery job to execute the SQL that will be used to NOT require password change at next logon. This is needed because API users are not interactive. In  the custom query job, provide the below SQL and execute the job. Make sure the job is successful:
 
update users set localauthenabled=1, passwordexpired=0 where username='systemadmin';
 
3 – From Admin > Settings > Microservices…
  • turn on “Enable Connector Microservice”
  • provide credentials JSON. For example, below I am using systemadmin account for the connector microservice. The password was set in step 1 above.
 
{"username":"systemadmin","password":"********"}
 
Please can you look into the issue and help us with the progress.
 
Raised a saviynt ticket but they closed the ticket saying to raise request over->
 
We do not have access to the above link.
 
Can anyone help how to resolve the issue and successfully setup the connector?
 
Regards
3 REPLIES 3

sudeshjaiswal
Saviynt Employee
Saviynt Employee

Hello @AtrayeeDutta,

The user specified under the username must be associated with an SAV role with the privileged access feature, and could you please check the user have all the privileges?
If the credentials of the system admin user are changed, ensure that the same credentials are updated in the MS Credentials parameter in Microservice Configurations and then restart the application. 

Please refer:-
https://forums.saviynt.com/t5/identity-governance/unable-to-setup-sftp-connector-quot-get-config-fro... 


Thanks,

If you find the above response useful, Kindly Mark it as "Accept As Solution".

AtrayeeDutta
Regular Contributor
Regular Contributor

Hi,

User specified under the username, have privileged sav role, microservices is updated and restarted, still we are facing same issue.

Regards

sudeshjaiswal
Saviynt Employee
Saviynt Employee

Hello @AtrayeeDutta,

Can you please check the logs, what error do you see in the logs?

Thanks,

 

If you find the above response useful, Kindly Mark it as "Accept As Solution".