Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Schema File Upload of Entitlements Error - One of the Columns(...) is not mapped

Philip_Malmos1
New Contributor II
New Contributor II

We have created 2 files for uploading entitlements to an endpoint, 1 .sav and 1 .csv through Schema File Upload. However we're getting an error message: 

"One of the Columns(securitysystems,endpoints,entitlementtype,entitlement_value) is not mapped"

My .sav file:

FILE_NAME_STARTS_WITH=DiscApp_TEST_SYSTEM_Entitlement_Values
SKIP_NO_OF_LINES=1
FILE_IMPORT_DELIMETER=;
CREATE_SECURITYSYSTEM_IF_NOT_EXIST=NO
CREATE_ENDPOINT_IF_NOT_EXIST_IN_SECURITYSYSTEM=NO
CREATE_ENTITLEMENTTYPE_IF_NOT_EXIST_IN_ENDPOINT=NO
ENTITLEMENT_VALUES_NOT_IN_FILE_ACTION=NOACTION
SECURITYSYSTEMS,ENDPOINTS,ENTITLEMENTTYPE,ENTITLEMENT_VALUE,STATUS

my .csv file:

securitysystems;endpoints;entitlementtype;entitlement_value;status
TEST_SYSTEM;TEST_SYSTEM;Role;Shipping Assistant;1

Is this a bug? Any ideas to what I could be doing wrong?

I have tried using other delimiters such as ,

I have changed endpoint displayname to fit the endpoint name / same with security system, as I wasn't sure which attribute the file was targetting.

4 REPLIES 4

Saathvik
All-Star
All-Star

@Philip_Malmos1 : Change the SAV file content as below and see if that works

FILE_NAME_STARTS_WITH=DiscApp_TEST_SYSTEM_Entitlement_Values
SKIP_NO_OF_LINES=1
FILE_IMPORT_DELIMETER=;
CREATE_SECURITYSYSTEM_IF_NOT_EXIST=NOACTION
CREATE_ENDPOINT_IF_NOT_EXIST_IN_SECURITYSYSTEM=NOACTION
CREATE_ENTITLEMENTTYPE_IF_NOT_EXIST_IN_ENDPOINT=NOACTION
ENTITLEMENT_VALUES_NOT_IN_FILE_ACTION=NOACTION
SECURITYSYSTEMS;ENDPOINTS;ENTITLEMENTTYPE;ENTITLEMENT_VALUE;STATUS

 


Regards,
Saathvik
If this reply answered your question, please Accept As Solution and give Kudos to help others facing similar issue.

Amar_Simha
Regular Contributor
Regular Contributor

@Philip_Malmos1 : I think in the last line of SAV file the headers are delimited by comma (,) but in CSV those are delimited by semi colon (;). Can you try with matching the SAV & CSV file to use same delimiter?

Can you attach files, It seems your file have new line or space which is causing issue.


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

Philip_Malmos1
New Contributor II
New Contributor II

After some investigation it was test and concluded, that the .sav files are different between an Entitlement Import and an Account Import. I wrongly assumed they had the same setup.

For Entitlements:

This works: FILE_NAME_STARTS_WITH=

This does not: FileNameStartswith=

, delimiter works while ; delimiter does not

 

For Accounts:

This works: FileNameStartswith=

This does not: FILE_NAME_STARTS_WITH=

Both , and ; delimiter works