Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

sav role Advanced filter

ankitalande
New Contributor II
New Contributor II

Hii,

The list of users under "View Existing Access" is decided based on the configuration "Whom to Request" in the SAV role configurations. Please use "Request for self and users retrieved from advanced filter" to restrict the users in same jobcodedesc or their reportee only.

I tried abover HQL query but achieve only one use case that same jobcodedes 

1. select a from Users a where a.jobcodedesc='${users.jobcodedesc}' or a.owner=${users.id} or a.id=${users.id}

2. select a from Users a where a.jobcodedesc='${users.jobcodedesc}' or a.manager=${users.id} 

I cannot achieve 2nd use case that their reportees also show in Request access for others, it only show same jobcodedesc user list. I want both the use case- 1. same jobcodedes  2. there reportees as well.

please suggest the solution.

4 REPLIES 4

Raghu
Valued Contributor III
Valued Contributor III

@ankitalande  need pass value in single quote

select a from Users a where a.jobcodedesc='${users.jobcodedesc}' or a.manager='${users.id}' or a.id='${users.id}'

 


Thanks,
Raghu
If this reply answered your question, Please Accept As Solution and hit Kudos.

PremMahadikar
Valued Contributor
Valued Contributor

Hi @ankitalande ,

You query is working fine for me. (Working 24.1)

 select a from Users a where a.jobcodedesc='${users.jobcodedesc}' or a.manager=${users.id} 

The above query covers, Same jobcodedes  and User repartees as well.

Can you try it using JSON once: 

[{"for":"RequestAccessforOthers,ViewExistingAccess,UpdateUserRequest,RequestAccessOthersMultiUser","query":"select a from Users a where a.jobcodedesc='${users.jobcodedesc}' or a.manager= ${users.id}"}]

PremMahadikar_0-1715864599014.png

If this helps your solution, please Accept As Solution and hit Kudos

ankitalande
New Contributor II
New Contributor II

working now. Thanks

Dave
Community Manager
Community Manager

@ankitalande - To help other users who may have a similar problem, please click the "Accept As Solution" button on the reply that best answered your question.