Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Removing account privileges without conducting a review of extended access

Gopinath
New Contributor III
New Contributor III
Hi Team,
 
When we initially submit a request with start and end dates to add an account to the respective group, it functions as intended. However, when we request an extension for access to the same group before the end date, the extension task is successful. The issue arises because the original request automatically removes access, without verifying if a valid extended end date is in place.
 
Example: 
On October 26, 2023, we submitted an initial request with an end date of October 28, 2023, which was successful. However, on October 27, we submitted a extend access request with an end date of January 10, 2024, and access was still removed by the initial request.
 
Could you please suggest us, do we need to make changes in the Remove Access Json or?
 
Thanks,
Gopinath
6 REPLIES 6

Darshanjain
Saviynt Employee
Saviynt Employee

Hi @Gopinath 

Can you check once extended, what is the value stored in account_entilements1 table for those Account-ent mapping to check the end date, May be it is not storing the new end date and it is getting removed.

 

Thanks

Darshan

Gopinath
New Contributor III
New Contributor III

Hi @Darshanjain 

Yes, it's not storing the new end date in the Account-Ent table.

I've submitted a request to update the Access End Date to November 30, 2025. However, the table continues to display the previous end date, but the task completed successfully.

Could you kindly advise us on the necessary next steps?

Gopinath_0-1700484275360.png

Gopinath_1-1700484640117.png

 

Thanks,

Gopinath

This may be issue in v5.5 Please upgrade version to EIC and validate 


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

Gopinath
New Contributor III
New Contributor III

Hi Team,

Can anyone please help on this issue?

Thanks,

Gopinath

Hi @Gopinath 

Can you let us know in which version you are seeing the issue as the latest versions end date is getting updated correctly.

 

Thanks

Darshan

Gopinath
New Contributor III
New Contributor III

Hi @Darshanjain ,

Thanks for the inputs.

In our project, the PROD environment currently exists with version 5.5 SP.16, while the Non-Prod instance has recently been migrated and is now running version V23.11. The end date is updating as expected in the latest version. We are currently in the process of migrating the PROD environment.

Thanks for the help.

 

Kind Regards,

Gopinath