Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Remove account versus disable account for disconnected application

PascalMontreuil
New Contributor III
New Contributor III

Hello, 

So in SAVIYNT when we do an access request for one of our disconnected applications we are able to give the user 2 options, the blue Delete button or the Disable/Enable in the 3 vertical ...

For the delete button, we understand and already tested this, this will completely remove the account of the user of that application, so if ever that user wants to access back that application he won't be able to.  We don't want that.

So disable account option is great for us, and it use to work, but while testing back today we've notice something strange.  The Disable option has the same behavior has the Delete button.  Before, once the Disable Task was completed, the user was able to select Enable option but now the applications is not even in is profil and if we do an access request, same a Delete, the account is gone and won't be able to request access.  So we are a bit suprise by this, here are some image of that use case and some screen shot of the test endpoint

[This post has been edited by a Moderator to embed the images.]

1 (4).jpg

2 (1).jpg

3 (1).jpg

4 (1).jpg

Pascal Montreuil
3 REPLIES 3

rushikeshvartak
All-Star
All-Star

Once remove account request is raised , account will be marked as suspended from import service after next recon hence this is expected behaviour


Regards,
Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.

PascalMontreuil
New Contributor III
New Contributor III

Ok, we've notice something, in 2021 the behavior is fine but in 2023 it's completely removing the account on a disable request, that should not be fine. Im sure that on a disable account that the user should not lose is Account and should be able to request a enable account

Pascal Montreuil

PascalMontreuil
New Contributor III
New Contributor III

We found the solution, it was in the Globat Configuration - Request, we've check this box : Show Inactive Accounts in ARS

Now working as is suppose to.

Pascal Montreuil