We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

Oracle EPM Account status not updating properly

bala
New Contributor II
New Contributor II

Hi Team,

We have Oracle EPM Application on-boarded as per below Saviynt documentation. 

https://docs.saviyntcloud.com/bundle/OracleEPM-v24x/page/Content/Understanding-the-Integration-betwe...

All seems to be fine except the Account status.  As we all know Account status its determined by STATUS_THRESHOLD_CONFIG_JSON especially statusColumn and activeStatus configs.  As per EPM Document its been Customproperty1 which has value 1 marked as Active Status. 

Can I know which is the corresponding attribute in EPM side. Because in Prov we are not passing the status and some how during import Saviynt checks for statusColumn CP1 which has value 1 for active in our case we don't have that CP1 value for the Account which Saviynt Provisioned. Even after multiple Account import process status not changing to active it was inactive always since CP1 is not populating for the account which Saviynt provisioned. 

Note json are same as per document. 

My questions are

1.  what is CP1 attribute corresponding EPM attribute? 

2. Do I need to pass and status attribute while provisioning EPM Account? 

bala_0-1706863395355.png

bala_1-1706863500081.png

[This message has been edited by moderator to mask URL info from an image]

11 REPLIES 11

rushikeshvartak
All-Star
All-Star

Do you Account CP1 for existing accounts not created from saviynt


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

bala
New Contributor II
New Contributor II

Yes, existing Accounts in EPM has CP1 value as 1 while doing import process, but Accounts created by Saviynt is not having the CP1 value.  What is missing here. In create Account json, we pass only FN, LN, Email and USER_LOGIN. Do I need to pass any other attributes? Since Import process is totally encapsulated in Saviynt I'm not sure which is the EPM Value attribute determined for CP1 mapping also. 

when account is created from saviynt you map customproperty 1 as 1 using responseColsToProp Const variable 


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

bala
New Contributor II
New Contributor II

Hi Rushikesh,

I tried the above logic you suggested, still the accounts created by Saviynt do not have CP1 as 1 during prov and also, they are set to inactive while running Import jobs. I have attached all the data needed for analysis. Steps with screenshots are added and logs are attached.   Since Saviynt ticket are redirected to Forum, we need support on this issue. 

{
"encryptAttribute": "password",
"statusAndThresholdConfig": {
"accountThresholdValue": 1000,
"accountEntThresholdValue": 500,
"inactivateEntsNotInFeed": true,
"deleteAccEntForActiveAccounts": true,
"statusColumn": "customproperty1",
"deleteLinks": false,
"correlateInactiveAccounts": true,
"inactivateAccountsNotInFile": false,
"activeStatus": ["1"],
"entThresholdValue": {
"entType": {
"Group": {
"ent": 1000
}
}
}
}
}

Thanks. 

 

Share create account json where you have updated const in colsrespone


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

Darshanjain
Saviynt Employee
Saviynt Employee

Hi @bala ,

I have checked the logs and its not complete, i see that for all accounts customproperty1 was trying to get updated, the main status is being calculated at the end of the job with log line- Inside markAccountStatus .

Can you check the last few lines of jobs when it stopped or send the logs of the last part only.

 

Thanks

Darshan

bala
New Contributor II
New Contributor II

Team, any updates?

bala
New Contributor II
New Contributor II

 @rushikeshvartak 

All the details are available in the attached document. Added all test screenshots also. Please check the attached documents and also the logs are attached. Thanks.  

There is no create Account JSON attached


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

bala
New Contributor II
New Contributor II

bala_0-1707807254345.png

 

bala
New Contributor II
New Contributor II

Any updates on this please, I have provided all details.