We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

Incremental Access import for Azure AD in NON-PROD/TEST env is not working

Diptansu11
New Contributor III
New Contributor III
Hello Team, 
 
We have onboarded Azure AD connector in Saviynt and executed first time Full access import in nonprod env and it went well. But after that when we tried to do incremental access import its not pulling the changes. To reproduce that we have added some new group memberships with an existing user and ideally upon incremental access import job it would have pulled those new groups in Saviynt but its not working . Where as when we are trying for full access import it is working. In Both the cases task is successful no error but not working as expected.
3 REPLIES 3

sudeshjaiswal
Saviynt Employee
Saviynt Employee

Hello @Diptansu11 ,

Do you see any error in the logs, when you run the incremental import.

Thanks

No error is logs at all just that when we run incremental import its not pulling the new groups but if we run full import it is working fine and pulling new groups so working as expected.

sudeshjaiswal
Saviynt Employee
Saviynt Employee

Hello @Diptansu11,

Can you run the below query in the analytics and check if the deltatoken is present 

select * from externalconnattvalue where CONNECTIONTYPE=395;  (Please change the connectionstype as per your connection)

is the detla token is null or have the value in the groupOwnerDeltaToken and  AADGroupDeltaToken are getting updated whenever you run the full/incrememtal import.
And try use the delta token in the postman and see if the token is valid,

Thanks,