Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Incoming Mail ARS job is not working and showing an error message.

AS5278
Regular Contributor II
Regular Contributor II

Hi,

We recently changed to OAuth for the Incoming Mail ARS job (Actionable email job).

We are not seeing any response in the Job log and the email-based approval is not working. When an approver approves through mail, that email is being received in the Inbox. But Saviynt is not able to process it.

The error in the logs is:

{"log":"2023-01-25 17:32:23,331 [quartzScheduler_Worker-8] ERROR services.EmailerService - Exception in pullObjectsByRest : 403\n","stream":"stdout","time":"2023-01-25T17:32:23.331330185Z"}

Also, I wanted to make sure I am configuring everything correctly in the SMTP configuration.

I have provided the Client ID, Tenant ID, Client Secret, User ID, Message Starts With, Folder Name

I have provided the Usern ID as:  "user@domain.com".

Is this the correct format of User ID or is it something else?

I am attaching the relevant screenshots. 

1.png

1 (1).png

[This post has been edited by a Moderator to remove the images as attachments and to embed them into the post.]

xurde
3 REPLIES 3

rushikeshvartak
All-Star
All-Star

You have issue with authentication, Validate Client ID/Secret 


Regards,
Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.

StaceyG
New Contributor II
New Contributor II

We are having this exact issue, too. Did you find a solution? I do not think it is a secret issue because we are both able to connect and send mail on behalf of the mailbox. 

Refer https://forums.saviynt.com/t5/identity-governance/oauth-email-invalid-user-error/m-p/23176#M11776


Regards,
Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.