Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Inactive status is not updating in Saviynt for Connection Type: Rest

Gopinath
New Contributor III
New Contributor III

Hi Team,

When we executed the 'AccountImportJob_ServiceNow_PrivilegedAccounts', all the account information updated in Saviynt as expected.
However, we encountered an issue wherein the inactive status from ServiceNow Privileged system did not reflect accurately in Saviynt. Despite having inactive accounts in the target system, Saviynt does not show a single inactive account.

Could you kindly recommend the necessary modifications we should make to the account import JSON in order to ensure that the 'Inactive' status gets updated in Saviynt?

Connection Type: Rest

Note: Connection and jobs status is showing as success.
I have attached the full logs while job is processing and Import Account Json as well.

Thanks,

Gopinath

13 REPLIES 13

pmahalle
All-Star
All-Star

Hi @Gopinath ,

Are you using REST connector for Service Now? Make sure to configure STATUS_THRESHOLD_CONFIG in you connection as below and try once.

{
"statusAndThresholdConfig": {
"accountThresholdValue": 1000,
"inactivateAccountsNotInFile":true,
"statusColumn": "customproperty21",
"activeStatus": [
"TRUE","true","True",true
]
}

}

In above example replace customproperty21 with your account attribute where you mapped the status column from ServiceNow.


Pandharinath Mahalle(Paddy)
If this reply answered your question, please Accept As Solution to help other who may have a same problem. Give Kudos 🙂

SumathiSomala
All-Star
All-Star

@Gopinath did you configure the STATUS_THRESHOLD_CONFIG in Connection?

{
"statusAndThresholdConfig": {
"accountThresholdValue": 50,
"statusColumn": "customproperty12",
"activeStatus": [
"true","TRUE","True"
],
"deleteLinks": false,
"correlateInactiveAccounts": true,
"inactivateAccountsNotInFile": "true"
}
}

and map status colum in accountParams

Sample mapping

"CUSTOMPROPERTY12": "active~#~char",

Regards,
Sumathi Somala
If this reply answered your question, please Accept As Solution and give Kudos.

Gopinath
New Contributor III
New Contributor III

Thank You for the quick response and solution @pmahalle  @SumathiSomala 

I have added the STATUS_THRESHOLD_CONFIG in connection. Account terminated status is updated to Saviynt successfully, but inactive accounts didn't update.

I have updated the Status threshold and import account Json below.

The job failed with below error message.

Gopinath_0-1698409531628.pngGopinath_1-1698409569396.png

Thanks,

Gopinath

 

@Gopinath Could please update the mapping in ImportAccountEntJSON and then try

"CUSTOMPROPERTY33": "u_active~#~char"
 "status":"u_active~#~char",

 

 

Regards,
Sumathi Somala
If this reply answered your question, please Accept As Solution and give Kudos.

Yes, I have tried with u_active as well but still job failed with same error.

Thanks,

Gopinath

@Gopinath Could you please share the updated JSONs and logs.

Also check CP33 is populated with status or not

and also share the possible values for active and inactive status in target.

Regards,
Sumathi Somala
If this reply answered your question, please Accept As Solution and give Kudos.

According to our requirement, there is no need for the 'statusColumn': 'customproperty33' in the STATUS_THRESHOLD_CONFIG. I've deleted it, executed the job and job processed successfully, and verified that the data from the target and both looks same.

Thanks,

Gopinath

@Gopinath : If your status column from target is boolean value like true or false then you don't need to map to custom attribute in colstoProsMap also "statusColumn": "custompropertyxx" is not required in statusAndThresholdConfig. It is only required if you need to translate the status of target to the values that saviynt understands

Based on the logs and JSON you have shared you are missing statusAndThresholdConfig.

You need this setting either in your ImportAccountEntJSON or at connection level configured. 

If you include that it should work as expected.


Regards,
Saathvik
If this reply answered your question, please Accept As Solution and give Kudos to help others facing similar issue.

Gopinath
New Contributor III
New Contributor III

Thanks for the detail explanation.

Now it’s working as expected.

Kind Regards,

Gopinath

soumyabrata
New Contributor III
New Contributor III

@Gopinath I am also facing the exact same issue.

Can you please provide your ImportAccountEntJSON/statusAndThresholdConfig which worked for you?

@soumyabrata Try below statusAndThresholdConfig

{
"statusAndThresholdConfig": {
"accountThresholdValue": 100,
"activeStatus": [
"true","TRUE","True"
],
"deleteLinks": false,
"correlateInactiveAccounts": true,
"inactivateAccountsNotInFile": "true"
}
}

 

Regards,
Sumathi Somala
If this reply answered your question, please Accept As Solution and give Kudos.

This I already tried but not working.

@soumyabrata : Can your share the postman response for the import call, and current import JSON you have used to help you better


Regards,
Saathvik
If this reply answered your question, please Accept As Solution and give Kudos to help others facing similar issue.