We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

Error on Create User Request and User Update Request

DavidK
New Contributor II
New Contributor II

Hello,

after submitting a user update or user create from the home screen option Create User Request or User Update Request this error message pops up

DavidK_0-1702391257203.png

User modificatations are on auto-approve and I reduced the create/update user form to the following

DavidK_2-1702391730695.png

The error does only occur on our development tenant and not on the productive tenant. I have attached the log file but can't find any error. Did anyone had the same issue and what was the solution?

Kind regards,
David

8 REPLIES 8

rushikeshvartak
All-Star
All-Star

Try deleting username attribute


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

DavidK
New Contributor II
New Contributor II

Hi,
I removed the username and a user update failed again. Then I removed all attributes and recreated the firstname attribute but this fails again.

DavidK_0-1702454050904.png

Rajesh-R
Saviynt Employee
Saviynt Employee

@DavidK  - Was there any recent upgrade on the Dev Env?

If yes - then check if you have any customizations on createupdateuserrequestfirststep.gsp. The customization might not allow the latest version of the file to be applied. 

If that is the case, you have to revert createupdateuserrequestfirststep.gsp to the base version of the product's version and reapply your customizations on the latest page.

Keep us posted.


Thanks
Rajesh Ramalingam
Saviynt India

DavidK
New Contributor II
New Contributor II

Hi,

the only file that was changed was customer/create.gsp but reseting this to the base version and restarting the services did not solve the error.
Do you have more things we can try?

Kind regards,
David

Which all browser you tried ?


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

I normaly use Google Chrome but I tested this with Firefox as well.

Rajesh-R
Saviynt Employee
Saviynt Employee

@DavidK  - I am assuming, Dev Env has gone through an update from your response. Suggest to reach out to your Operations team to confirm if everything is okay with the latest deployment. 

Could you also check if there are any other recently updated versions for createupdateuserrequestfirststep.gsp and make sure that this file is in the base version.


Thanks
Rajesh Ramalingam
Saviynt India

DavidK
New Contributor II
New Contributor II

Hi Rajesh,

I got the error checked out and it's now resolved. It was resolved by importing an unmodified version of the createupdateuserrequestfirststep.gsp from a fresh instance.

Thanks and kind regards,
David