Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

EPM Imports not working after upgrading to v23.11

AS5278
Regular Contributor II
Regular Contributor II

Hi,

We have used the EPM Connector to integrate EPM application with Saviynt. The import jobs were working fine when we were in version 23.8. After we upgraded to version 23.11, the job is not working properly. The job status shows as 'Success' but the last run and job end date is blank.

AS5278_0-1704838788355.png

We could see in the logs that the processing is happening in fact but the transaction is getting rolled back due to some exception.

Below is the only error message we could see every time we run the EPM3 import job:

AS5278_1-1704838925531.png

"not-null property references a null or transient value : com.saviynt.ssm.entity.AccountEntitlements1.updateuser"

We are breaking our heads since weeks and unable to figure out what is wrong. We have also created a support ticket with Saviynt. But it is pending since long. This issue started after upgrading to 23.11 from 23.8...not sure whether with each version release Saviynt is getting upgraded or downgraded.

Please advice. Attaching the logs...

Thanks,

Atul Singh

 

xurde
5 REPLIES 5

rushikeshvartak
All-Star
All-Star

Does connector have config JSON for timeout ?


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

AS5278
Regular Contributor II
Regular Contributor II

@rushikeshvartak 

Oracle EPM Connector type did not have the 'ConfigJSON' field. We had added it manually by modifying the Oracle EPM Connection Type so that we can see detailed logs.

AS5278_0-1704880621505.png

 

xurde

Add Connection Timeout configs

{
"connectionTimeoutConfig": {
"timeout": 300,
"retryWait": 100,
"retryCount" : 3
}
}


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

AS5278
Regular Contributor II
Regular Contributor II

I added the ConfigJSON like below and ran the import job:

{
"showLogs": true,
"connectionTimeoutConfig": {
"timeout": 300,
"retryWait": 100,
"retryCount": 3
}
}

But we are still seeing the same error in logs and the job last run and end date is blank.

AS5278_0-1704968758851.png

AS5278_1-1704968804659.png

 

xurde

It seems code issue. Please check with saviynt support


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.