Detective Provisioning Rules Job not triggering detective rule

Regular Contributor
Regular Contributor



When I run the detective provisioning rules job it doesn't trigger my technical rule that is assigning an enterprise role. When I check the preview on the rule I can see the list of users, however these users aren't being assigned the role and no tasks are being generated. No errors in the logs and the job is completing successfully.

Below is my rule.





share logs once job is executed. use advance query instead of many or condition

I don't believe that is the issue. The detective job completes almost immediately with no errors in the error log.

Please also note the label says Deprecated on the job. I believe I had this issue for a previous client, in one environment the detective job did not say deprecated and worked but in a higher environment it said deprecated and Saviynt had to do something on their end to fix the issue.



Check logs there should be some error

I've checked the logs, there is nothing pertaining to that particular rule. Error and Debug log attached. The technical rule is called "Enterprise - Engineering Level 1 (Unionized)" . The rule doesn't seem to be getting processed at all.

Under what conditions does a technical rule get evaluated? Does it not evaluate existing users that meet the condition if Detective is set in the rule?

I currently only have Detective set.


It is also not only this technical rule, none of the detective rules I created appear to be getting evaluated with the detective job.

Conditions should match to trigger rule

I'm not following what you mean. Can you elaborate? Based on the preview the conditions apply to multiple users, so not sure why it doesn't action the rule.