Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Defining table ssminlp.DATASET_VALUES to replace special characters

yusufw
New Contributor III
New Contributor III

I am trying to replace special characters using the preprocessor by following this link. but I keep getting the error "Table 'ssminlp.DATASET_VALUES' doesn't exist". How can I create the table so that I can replace special characters?

  1. I tried using the default dataset but FN_EIC_REPLACE(lastname,null) led to the error below
  2. I tried using my own dataset but FN_EIC_REPLACE(lastname,'SPECIAL_CHARS_ADATTRIBUTES') led to the error below: 

 

 

"ecm","2023-07-27T20:43:47.069+00:00","{"log":"2023-07-27 20:43:46,259 [http-nio-8080-exec-89] DEBUG services.ImportSAvDataUserService - Processing query..\n","stream":"stdout","time":"2023-07-27T20:43:46.259776671Z"}"
"ecm","2023-07-27T20:43:47.069+00:00","{"log":"27-Jul-2023 20:43:46.260 WARNING [http-nio-8080-exec-89] groovy.sql.Sql.executeUpdate Failed to execute: UPDATE TEMPNEWUSERS_262813 SET customproperty50 = FN_EIC_REPLACE(lastname,'SPECIAL_CHARS_ADATTRIBUTES') because: Table 'ssminlp.DATASET_VALUES' doesn't exist\n","stream":"stderr","time":"2023-07-27T20:43:46.260994798Z"}"
"ecm","2023-07-27T20:43:47.069+00:00","{"log":"2023-07-27 20:43:46,261 [http-nio-8080-exec-89] ERROR services.ImportSAvDataUserService - Error while processing data: \n","stream":"stdout","time":"2023-07-27T20:43:46.261813945Z"}"
"ecm","2023-07-27T20:43:47.069+00:00","{"log":"com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table 'ssminlp.DATASET_VALUES' doesn't

 

 

9 REPLIES 9

rushikeshvartak
All-Star
All-Star

Please share query and also try lowercase dataset_values


Regards,
Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.

I am not referring to DATASET_VALUES in the preprocessor, so there's no place to make it lower case. 

According to the Saviynt doc, I added the following to PREPROCESSQUERIES section of the preprocessor:

"UPDATE NEWUSERDATA SET customproperty50 = FN_EIC_REPLACE(lastname,'SPECIAL_CHARS_ADATTRIBUTES')",

where SPECIAL_CHARS_ADATTRIBUTES is a dataset I created. It has two columns: searchChar,newChar, and it has values like "Á,A"

Looking at error it seems you can't use dataset_Values / refer inside preprocessor 


Regards,
Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.

yusufw
New Contributor III
New Contributor III

@rushikeshvartak 

Please read the Saviynt doc and my previous comment, I am NOT calling dataset_values in my preprocessor.  

Please ask engineering about this issue.

Do you have below dataset SPECIAL_CHARS_ADATTRIBUTES under datasets in admin ? if yes does it have values , Please provide screenshot


Regards,
Rushikesh Vartak
If you find this response useful, kindly consider selecting 'Accept As Solution' and clicking on the 'Kudos' button.

I do but it has no dataset_values. What values should go into it?

yusufw_0-1690493254717.png

 

Hi Rushikesh V

Please provide an update on this issue. I need to know how to remove special characters from identity data because using REPLACE statements is not feasible when there's a lot of characters to replace.

I've searched through the forums and no one seems to have gotten it to work. If Saviynt EIC doesn't with the db function fn_eic_replace , it shouldn't be documented in https://docs.saviyntcloud.com/bundle/EIC-Admin-v23x/page/Content/Chapter03-User-Management/User-Impo...

 

prajakta
New Contributor III
New Contributor III

Hi ,

Here is the response we received from Saviynt on the FD raised for the same issue on v23.5. 

This is known issue with FN_EIC_REPLACE  , an internal jira created for this issue and will let you know the fix version once jira is closed

Thanks

mbh_it
Regular Contributor II
Regular Contributor II

Hi All,

I am facing this issue, is this resolved yet?

Thanks

Mahesh