We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

Default value not populating in Endpoint Dynamic Attribute

h_sapkota
Regular Contributor
Regular Contributor

Hi All,

I have created two dynamic attribute selectRole and region. selectRole is DA to get the input from user in which user Selects a ROLE and based on the selectRole, region DA should be automatically populated as default value.

To achieve this, we use Single Select from SQL Query (BOTH in Parent and Child).

For Child we used same query mentioned below in both Values and Default Section. Values section query execute without any error but the query in the default section throws error as viewed in logger. Default value will work properly if we do not use any binding variable of Dynamic attribute or use hard coded value. The issue is Default value is not populated in the form.

Parent Attribute: selectRole
Query: SELECT distinct ATTRIBUTE1 as ID from dataset_values where datasetname = 'TestRole'

h_sapkota_0-1702715612001.pngh_sapkota_1-1702715627041.png

 

Child Attribute: region
Value Query: 
select distinct attribute2 as ID from dataset_values where datasetname = 'TestRole' and attribute1 = ${selectRole}
Default Query: select distinct attribute2 as ID from dataset_values where datasetname = 'TestRole' and attribute1 = ${selectRole}

h_sapkota_2-1702715799622.pngh_sapkota_3-1702715811238.png

Please note:
1.We have tried removing Mapping from What action to perform when parent attribute changes? in child DA.
2.We have tried using Refresh in What action to perform when parent attribute changes? in child DA. None of these seems to work.

Note: Dataset used and Error logs have be attached here.

Similar issue was raised but seems like no solution was provided.
https://forums.saviynt.com/t5/identity-governance/issue-with-populating-default-value-for-the-endpoi...

3 REPLIES 3

rushikeshvartak
All-Star
All-Star

Default value only populated on parent attribute and not on child attributes


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

Manu269
All-Star
All-Star

@h_sapkota I am able to populate teh default valus on prent attribute.

Anyhow I dont this to be feassible for child attributes.

 

Regards
Manish Kumar
If the response answered your query, please Accept As Solution and Kudos
.

h_sapkota
Regular Contributor
Regular Contributor

The issue I was facing is resolved using CLASSICAL UI FOR application request.

In Classical UI, default value can be populated in Child Attribute using dependency from Parent Attribute.