We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

CreateUserRequest API is not working

AravindK
Regular Contributor
Regular Contributor

Hi Team,
We are using the below API to create the user request but we are getting the below response and the below mentioned error.

AravindK_0-1702570656359.png


Same API and paramters are working fine in 5.5.Sp.18 but in 23.9 version it is not working .

We also used V5 in Api but still no luck. Same data is working for the createUser API but not for createUserRequest API

Error in the logs :
groovy.lang.MissingMethodException: No signature of method: com.saviynt.ecm.services.changeaction.UserChangeActionService.createRequest() is applicable for argument types: (java.util.HashMap, null, java.lang.Boolean, com.saviynt.ecm.identitywarehouse.domain.Users, null) values: [[owner:24335909, country:India, firstname:Raja, ...], ...]

We have configured the workflow under user modifcation workflow in Global config and tried by making the approval as auto approve but still same error.

Can you please help what else missing?


11 REPLIES 11

rushikeshvartak
All-Star
All-Star

content type should be form data not raw - text


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

Rajesh-R
Saviynt Employee
Saviynt Employee

Please use the following content type:

It looks like you are passing a JSON - but the Content Type is not defined as JSON.

 

Content-Type:application/json

 


Thanks
Rajesh Ramalingam
Saviynt India

On API documentation shows form data 

rushikeshvartak_0-1702612155011.png

rushikeshvartak_1-1702612164461.png

 


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

AravindK
Regular Contributor
Regular Contributor

Hi @rushikeshvartak  Even with Form Data also same error. 

AravindK_0-1702612594336.png

 


In 5.53.18 version both ways(form data and raw text is working fine perfectly.

In 23.9 createUser Api is working fine but CreateUserrequest API is not working.

@Rajesh-R  yes if we are passing JSON then in headers we are passing the content type as application/json. If it is text , content type is text/plain.



Can you share attributes configured in global config

rushikeshvartak_0-1702613709703.png

 


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

AravindK
Regular Contributor
Regular Contributor

Hi @rushikeshvartak ,
Please find the screenshots :

AravindK_0-1702614692204.png


AravindK_1-1702615205018.png

 

 

Please pass all above parameters which are required and visible on create user form


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

AravindK
Regular Contributor
Regular Contributor

Hi @rushikeshvartak ,
We tried and now we are getting below response .

AravindK_0-1703088312575.png

 

Please share curl command [Refer https://codingnconcepts.com/postman/how-to-generate-curl-command-from-postman/ ]


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

AravindK
Regular Contributor
Regular Contributor

Hi @rushikeshvartak ,
Please find the Curl response.



curl --location --request POST 
'https://ENV_URL/ECM/api/v5/createUserRequest' \
--header 'Content-Type: application/json' \
--header 'Authorization: Bearer eyJhbGciOiJIUzI1NiJ9.eyJwcmluY2lwYWwiOiJINHNJQUFBQUFBQUFBSlZTejA4VFFSajlkaW1CUUlKZ29ra1BjQkZ2Wm12RVJFZ3ZsbDhHczdZTjI1cUlpV1M2T3l3RHN6UHJ6Q3kwRjlLVEhqaGdWQklUXC93WCtFNzM0QnhnOWVPWHMxVysyd0ZZdnhEbHQzcng1NzMzZjI3TnpHTlVLRm1KRkdOZGV5ck9ZQ1UrbmlvbFkwekJUelBTOFRGTVZVWk16bnVURU5pSXdPSTRMamc4dWl3emM5UGZJQWFsd0l1SktvN05IUTFQdEtuZ2dWWHlodUtOSVFnK2wydmV1dEVPcDZGOEdoYlR6MklXeExaZ2hZU2d6WWVwU3JIVlRwbWkwQmRNRjVzdHczMEszUXJ5aHdqREM5VEIxakFyUzRUVHlZWkprWmxlaUs2UGF3STFCMk13d1hnbW9xZm93bmhLdE1kMFwva3dUR1JyZjNOcWJBQ1Y3REVaUzZxWU1IZDNmWFVqMnI0NjFJem5GcUpvV2ViNHRFUm15SFdYUFU3OCsrXC8zYnl1ZDkyQVhBbjk2NVwvVStEbFplaFwvZWZWN0xsKzBFeHE0UFJTOW9GVzdLYWFaS1pSYmlscm43NSthSDA3UDM3NGNRV2ZMV1BcL1wvUHVackY1dnJyY2drSllvWU9kUVJ5aDZXOE50RjhlWHJ4UzliNkhrQlMxSk84WThTaGtaWEZvVXdqbHRTa2xcL3UyOERFWnNOZjI2NnRQdHVvYXd0T0dTZ1gwSFpRZTc3eG90NEsyczFtWTdObEg0d1wvdXIrMHVMVHdjQkdqVGVXYnNaVjZ2c1JDajMrOSszcHk1d2ZhUElYUkE4SXppc1ZNRjZSNmxuU29lbk4yT2p2NThlZHhQdVlnV2JueEI1NzBCb1kyQXdBQSIsInN1YiI6IjcwOTg5MzQ4IiwiZXhwIjoxNzAzMTAxMDUxLCJpYXQiOjE3MDMwOTc0NTEsInJvbGVzIjpbIlJPTEVfQURNSU4iLCJST0xFX0FETUlOX1NBVklZTlRTVVBQT1JUIl19.on5R9MPwcrdkYck7tPJ83G1SZfODjPEdigtGHVezO0g' \
--header 'Cookie: CCSRF-TOKEN=94b08491-379f-411f-b740-716aeeed8c04; INGRESSCOOKIE=1703097452.535.312.988876|0f4091fceac04271d9e9e5a60a3d3e8f; access_token=eyJhbGciOiJIUzI1NiJ9.eyJwcmluY2lwYWwiOiJINHNJQUFBQUFBQUFBSlZTejA4VFFSajlkaW1CUUlKZ29ra1BjQkZ2Wm12RVJFZ3ZsbDhHczdZTjI1cUlpV1M2T3l3RHN6UHJ6Q3kwRjlLVEhqaGdWQklUXC93WCtFNzM0QnhnOWVPWHMxVysyd0ZZdnhEbHQzcng1NzMzZjI3TnpHTlVLRm1KRkdOZGV5ck9ZQ1UrbmlvbFkwekJUelBTOFRGTVZVWk16bnVURU5pSXdPSTRMamc4dWl3emM5UGZJQWFsd0l1SktvN05IUTFQdEtuZ2dWWHlodUtOSVFnK2wydmV1dEVPcDZGOEdoYlR6MklXeExaZ2hZU2d6WWVwU3JIVlRwbWkwQmRNRjVzdHczMEszUXJ5aHdqREM5VEIxakFyUzRUVHlZWkprWmxlaUs2UGF3STFCMk13d1hnbW9xZm93bmhLdE1kMFwva3dUR1JyZjNOcWJBQ1Y3REVaUzZxWU1IZDNmWFVqMnI0NjFJem5GcUpvV2ViNHRFUm15SFdYUFU3OCsrXC8zYnl1ZDkyQVhBbjk2NVwvVStEbFplaFwvZWZWN0xsKzBFeHE0UFJTOW9GVzdLYWFaS1pSYmlscm43NSthSDA3UDM3NGNRV2ZMV1BcL1wvUHVackY1dnJyY2drSllvWU9kUVJ5aDZXOE50RjhlWHJ4UzliNkhrQlMxSk84WThTaGtaWEZvVXdqbHRTa2xcL3UyOERFWnNOZjI2NnRQdHVvYXd0T0dTZ1gwSFpRZTc3eG90NEsyczFtWTdObEg0d1wvdXIrMHVMVHdjQkdqVGVXYnNaVjZ2c1JDajMrOSszcHk1d2ZhUElYUkE4SXppc1ZNRjZSNmxuU29lbk4yT2p2NThlZHhQdVlnV2JueEI1NzBCb1kyQXdBQSIsImlzcyI6ImhpdGFjaGllbmVyZ3ktZWljLWRldi5zYXZpeW50Y2xvdWQuY29tIiwic3ViIjoiNzA5ODkzNDgiLCJleHAiOjE3MDMxMDEwNTEsImlhdCI6MTcwMzA5NzQ1MSwicm9sZXMiOlsiUk9MRV9BRE1JTiIsIlJPTEVfQURNSU5fU0FWSVlOVFNVUFBPUlQiXX0.FYN3VHNbtnj1YI-DnukVJmvg4-0jDBsxTGwhkgmLnPc; token_type=Bearer; user_name=70989348' \
--data-raw '{
"firstname":"myfirstname",
"lastname":"hello",
"startdate":"10-18-2018",
"owner":"70989348",
"customproperty60":"HE",
"passwordExpired":"true",
"enabled""true",
"accountExpired":"true",
"accountLocked":"false",
"country":"India",
"email":"gysdeia.herman@gmail.com"
}
'

Remove email field as per your error and try 

I hope you dont have any regex validation over email


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.