Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Connection to custom jar file

New Contributor
New Contributor

Apologies if this is covered somewhere else. I've searched the forums and the knowledge base.
I've got a custom jar file that I want to use for user creation, recon etc.

If I trigger the recon directly from a job using the invoke extension jar job, it runs successfully. I can see the jar executing in the log files and it returning the recon json.

But I can't get this same jar file to trigger from a connection (using the jarconnector connection type)
I've read this -
But I'm not sure how to connect to my jar file
Where the doco says to have a connection json as 
"url": "",
"username": "User_Name",
"password": "PASSWORD"

Is this to connect to the saviynt jar file server, and I need to substitute my saviynt cloud URL, admin username/password in here. Or are these details that its passing as arguments to my jar file for connectivity to the target application. Or do I just leave these details as is.

Similar for the import account json
I've tried multiple combinations of this, and cant get the method to trigger (I can see all of my arguments being listed in the log file, but the method doesnt execute.
I've substituted the fully qualified class name and method name (exactly the same as the details in the job I ran that worked). But how many of these other items do I need, as I've written the jar (at least temporarily) to not need any args passed to it.
"fullyQualifiedClassName": "com.jar.jar",
"methodName": "accountImport",
"arguments": {
"connect_url": "${connectionJSON.url}",
"connect_username": "${connectionJSON.username}",
"connect_password": "${connectionJSON.password}",
"endpoint": "JAR",
"securitySystem": "JAR"
"targetToSourceMappingJSON": {
"": "accountName_character",
"accounts.description": "Description_character",
"accounts.Status": "Status_character",
"endpoints.endpointname": "endpoint_character",
"securitysystems.systemname": "securitySystem_character"
When I run the account import using this connection, this is what it looks like in the logs
After a log entry for each call in the jar connector and for each arg
I get this


where its saying that the jar file is initiated, but then it completes straight away

I'm sure its a simple fix, and I'm missing something obvious. But I've been looking at it all week and going around in circles. Any help would be appreciated