Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

Broken Entra ID Connections - Following required connection parameters are missing - [ENVIRONMENT]

Murmur
Regular Contributor III
Regular Contributor III

Hi everybody, 

I noticed, that since we upgraded to v24.5, the Design Module is not able to create working Import Connections for Microsoft Entra ID anymore. 

It was working flawlessly before that. Now, when you try to set up a new Entra ID Application, you receive the following error, when you click Test Connection

Murmur_0-1717753013350.png

Rest assured, that the IDs, as well as the secret are specified correctly. 

Do you have any clue, how to approach that issue? 

EDIT: Add Error Message as Text for Search Purposes "Connection Failed. Following required connection parameters are missing - [ENVIRONMENT]"

Cheers 🙂

4 REPLIES 4

rushikeshvartak
All-Star
All-Star

Yes its broken solution 

There is an extra parameter (Environment) defined for AzureAD under connection type list:
rushikeshvartak_1-1717765827686.png

 

 

 


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

Murmur
Regular Contributor III
Regular Contributor III

Thanks for your quick reply @rushikeshvartak!

 

Does that mean we should delete the ENVIRONMENT parameter or what's you suggestion? 

Cheers 🙂 

yes delete it (Refer saviynt support solution

rushikeshvartak_0-1718072865302.png

 


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

Murmur
Regular Contributor III
Regular Contributor III

Update from Support: 

This is an already known issue and has been fixed in 24.7 version onwards.

Jira: CONN-18735