We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

Binding Variable Not working in REST Connector createAccountJSON

rohitkumarraj
Regular Contributor
Regular Contributor

Team,

I am working on REST Connector.

To create an account, passing user's basic info in httpParams as shown below in Create Account JSON, But instead of picking the actual value it's passing the binding variable as it is. 

JSON:

{
"accountIdPath": "call.message.id",
"responseColsToPropsMap": {
"customproperty5": "call.message.id~#~char ",
"customproperty1": "version~#~char"
},
"call": [
{
"name": "call",
"connection": "userAuth",
"showResponse": true,
"url": "https:URL/api/v2/users",
"httpMethod": "POST",
"httpParams": "{\"name\": \"${user.firstname} ${user.lastname}\",\"email\": \"${user.email}\",\"password\":\"Abcd1234$\",\"divisionId\":\"75558435-5a52-43bf-b8a5-bb703c152b\",\"state\":\"active\"}",
"httpHeaders": {
"Authorization": "${access_token}",
"Accept": "application/json",
"Content-Type": "application/json"
},
"httpContentType": "application/json",
"successResponses": {
"statusCode": [
200,
201,
202
]
},
"unsuccessResponses": {
"statusCode": [
400,
401,
403,
404,
429,
500,
503
]
}
}
]
}

Here, instead of passing user's firstname and lastname value from Saviynt, it is passing ${user.firstname} ${user.lastname} as it is to the target system. Hence user's account not getting created with actual name rather it name "${user.firstname} ${user.lastname}".

This is very weird behavior, never came across with this type of issue earlier.

Snapshot of Saviynt screen after running reconciliation for this account:

rohitkumarraj_0-1653904771816.png

 

Can anyone please suggest, what could be wrong here? Am I missing anything?

Thanks

Rohit

4 REPLIES 4

rushikeshvartak
All-Star
All-Star

Does your connection name is userAuth? 


Regards,
Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

yes, It's userAuth in connection name.

Point to note here: With the same JSON, when values are hardcoded then it is passing the actual hardcoded value. But when trying to capture the value using binding variable it doesn't work!

Rajesh-R
Saviynt Employee
Saviynt Employee

Hi Rohit,

Greetings.

Appreciate your analysis here. Just wanted to check, Does the password demand to have that character '$' ?

Just a wild try, Try out by removing the $ for the password and see if the binding variables are resolving?

Behaviour: Even if any one of the Binding variable is misspelt / misused, none of the binding variables get resolved. 

Keep us posted.

 


Thanks
Rajesh Ramalingam
Saviynt India

Awesome @Rajesh-R . Removing $ from password value resolved the issue.

Many thanks! Kudos to you!!