We are delighted to share our new EIC Delivery Methodology for efficiently managing Saviynt Implementations and delivering quick time to value. CLICK HERE.

Add user to organization during CSV import

niklasfa
New Contributor II
New Contributor II

Hello together,

I want to add users to an organization during CSV based user import. Whenever I do this, the user is updated but the organization name isn't set. I've added a new column "customer" to my CSV file (attached). I tried both adding the organization name ("Amigopod") and the organization id (4)  to this column. Both cases end up in the same result as describe.

niklasfa_0-1690361314338.png

niklasfa_1-1690361350034.png

niklasfa_2-1690361380441.png

niklasfa_3-1690361413952.png

Thanks in advance.

Kind regards,
niklasfa

8 REPLIES 8

naveenss
All-Star
All-Star

Hello @niklasfa  have you added the organization under the SAV role? If not please add it and retry the import.

Regards,
Naveen Sakleshpur
If this reply answered your question, please click the Accept As Solution button to help future users who may have a similar problem.

niklasfa
New Contributor II
New Contributor II

Hello @naveenss,

thank you for your reply. We have a couple of Saviynt roles in our instance.

Could you tell me which SAV role do I have to assign the organization to or does it depend on the context and can't be answered in general? It must be the SAV role which is associated witht my user, right?

Sorry for the basic questions, this is the first time working on organizations for me.

 

niklasfa_1-1690364301327.png

Thanks,

niklasfa

 

@niklasfa you need add it to the SAV role that you're using to import the users. 

Regards,
Naveen Sakleshpur
If this reply answered your question, please click the Accept As Solution button to help future users who may have a similar problem.

naveenss
All-Star
All-Star

@niklasfa below is the place where you need to add the orgs under SAV role

naveenss_0-1690364603438.png

 

Regards,
Naveen Sakleshpur
If this reply answered your question, please click the Accept As Solution button to help future users who may have a similar problem.

niklasfa
New Contributor II
New Contributor II

I did, thanks. Unfortunately it's still not working (organization name is empty). Please have a look on my configuration setup. Log is attached.

(ROLE_ADMIN is assigned to my user, I've checked it in the "Sav Role" tab in the user settings).

niklasfa_0-1690365424833.png

niklasfa_5-1690365570537.png

niklasfa_7-1690365671486.png

 

 

 

 

Hi @niklasfa ,

Seems like you have added organization/customer key in CSV. Can you try with organization name instead of key.


Pandharinath Mahalle(Paddy)
If this reply answered your question, please Accept As Solution to help other who may have a same problem. Give Kudos 🙂

Please pass the organization name in the upload file. 

Regards,
Naveen Sakleshpur
If this reply answered your question, please click the Accept As Solution button to help future users who may have a similar problem.

niklasfa
New Contributor II
New Contributor II

Thank you guys, it's working now.

Kind regards

Niklas