Active Directory connection error

New Contributor II
New Contributor II

Hi Saviynt Team,

I am not able to establish a connection between Saviynt and Active Directory Environment, getting a Connection timeout error. I see the SC2.0 server is able to communicate with the Server on port 636 as well as 389 and there is no firewall blocking that.

But when I am trying to create the connector i am getting below error on both 389 and 636 port


Please let me know what may be the issue

[This message has been edited to mask CN from image by moderator]




Valued Contributor II
Valued Contributor II

Hi @sppnra ,

Add below json in and try once:


{"envproperties": {"com.sun.jndi.ldap.connect.timeout": 10000,"": 50000}}

ConfigJSON :

"connectionTimeoutConfig": {
"connectionTimeout": 10,
"readTimeout": 50,
"retryWait": 2,
"retryCount": 3

Above JSONs are with default timeout configuration. You can increase it as per your requirement in case need more time to connect.

Refer below Saviynt document:


Pandharinath Mahalle(Paddy)
If this reply answered your question, please Accept it As Solution to help others who may have a similar problem.

New Contributor II
New Contributor II

Hey @pmahalle , 

I have tried that still getting the same error 




New Contributor II
New Contributor II

I am able to connect with Dev Instance but not with Test Instance, And I can see the SC2 client IP is up and running.

Please Note- SC2 Client IP is the same for both Dev and Test Instance but we have installed the SC2 IP on two different VM and both are up and running.

Please let me know what may be causing this issue