Announcing the Saviynt Knowledge Exchange unifying the Saviynt forums, documentation, training,
and more in a single search tool across platforms. Read the announcement here.

500 error while integrating on-prem Exchange with Saviynt

Regular Contributor
Regular Contributor

Hi Team.

We are facing difficulties in integrating on-prem exchange with Saviynt. Please find the details below:

  1. Configured IIS on the Windows server.
  2. As it is a dev environment, we are using a self-signed certificate and IP address for binding.


  1. Enabled PS execution on the Windows server.
  2. Able to successfully connect with Windows machine via Saviynt.


  1. But when we are triggering the PowerShell from Saviynt we are having 500 error-


  1. When we are trying to access http://<windows machine Ip>/<Saviynt app base URL>  (within the same machine), it shows resource not found issue. We tried both http and https

I think the Saviynt app deployment is the issue. We followed all the mentioned steps but might be something incorrect.


Please let me know if you have any ideas or suggestions.



Thank you, Rushikesh, 

We identified the issue. Our folder structure is as below:


When we are giving application path as, <Parent Folder>/Saviynt/WINPS, 


We receive the following error- 


When we are giving application path, <Parent Folder>/Saviynt/WINPS/Scripts, 



It is able to show the directory structure-


But now our WINPS connection fails.

So we had set up REST connector and we are trying to execute the following PS-

 "url": "",
"httpMethod": "POST",
"httpParams": "{\"Script\":\"Powershell.exe -File C:\/inetpub\/wwwroot\/Saviynt\/WINPS\/Scripts\/PS\/ExecutePSScript\/SampleSaviyntPrint.ps1 \"}",

but receiving the following error-


Tried to execute the same within machine still same error-


Not sure what is missing. Please let me know if you have any idea..

Check from postman

405 Method Not Allowed error code means that your browser has sent an HTTP request (GET, POST, PUT, etc.) that isn't allowed for that specific resource, or URL.

Rushikesh Vartak
If you find the response useful, kindly consider selecting Accept As Solution and clicking on the kudos button.

Hi @rushikeshvartak ,

Hi Tried to hit the URL from postman, and getting same in postman as well.




Do we need to change in config file or changes that we have make?? 

do we need to create PS and ExecutePSScript folder? Our file structure is below.




Specified path's in Default web site and Saviynt. Please check and let me know if any thing is required


for now we have created a script under "C:\inetpub\wwwroot\Saviynt\WINPS\Scripts\PS\ExecutePSScript" folder.


Regular Contributor
Regular Contributor

Hi Rushikesh,

I think the problem is with the handler. When we are invoking the REST command, it goes to StaticFileHandler, DefaultDocumentHandler. But these handlers do not support the POST method.

So which handler do we need to configure?






Hi @yatishtiwari @gwagh 

Could you please confirm if you have followed the WIN-PS connector guide, and at which point you have observed the issue? Understanding the Integration between EIC and Windows Server (

Any reason why you are not using WIN-PS connector rather than REST to run the PowerShell script?


Dhruv Sharma

Saviynt Employee
Saviynt Employee

Hi @yatishtiwari 

Please refer the below steps from the connector guide for the 4XX/5XX errors. Review the configuration and confirm. Also, as per the documents, physical path is the local folder path where you deploy the code. Please check and confirm.

Troubleshooting (

4xx or 5xx error Occurs while Deploying the Saviynt App


Dhruv Sharma


Regular Contributor
Regular Contributor

Thank you, Dhruv and Rushikesh. 

Although we are still having some problems, the original issue has been resolved. The problem was following-

1- We need to create PS and ExecutePSScript folders under Saviynt App.

2- Application Path should be set to <Parent>/SaviyntApp/WINPS (If WINPS is present )

3- Even if everything is correct when u try to access https://<IP/HOST>/<APPNAME> it shows resource not found but if you trigger REST API< it should work.

4- Execution Policy should be assigned to RemoteSigned.

Hope it helps others.

Hi @yatishtiwari 

Just checking if you need any further help on this issue. 


Dhruv Sharma

Regular Contributor
Regular Contributor

We can close this thread,